Bug 34733 - GL support not working for Voodoo 3000 out of box
GL support not working for Voodoo 3000 out of box
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: Mesa (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 11:25 EDT by Scott Russell
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-04 16:22:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 log file (29.49 KB, text/plain)
2001-04-04 11:27 EDT, Scott Russell
no flags Details
Config file (1.83 KB, text/plain)
2001-04-04 11:29 EDT, Scott Russell
no flags Details
Config file (1.83 KB, text/plain)
2001-04-04 11:29 EDT, Scott Russell
no flags Details

  None (edit)
Description Scott Russell 2001-04-04 11:25:35 EDT
A fresh 'workstation' install with a PCI 3dfx Voodoo 3000 adapter and Abit
KA7 mobo. XFree86 4.0.3 is configured okay (meaning video works) however GL
support is missing. 

tdfx kernel module is available and proper glide packages appear to be in
place however testing with GL apps shows unaccelerated software GL
rendering. To test I simply used the GL screen savers from
/usr/X11R6/lib/xscreensaver/.

What config files should be checked to ensure Gl is available and
configured correctly?
Comment 1 Scott Russell 2001-04-04 11:27:20 EDT
Created attachment 14646 [details]
XFree86 log file
Comment 2 Scott Russell 2001-04-04 11:29:13 EDT
Created attachment 14647 [details]
Config file
Comment 3 Scott Russell 2001-04-04 11:29:15 EDT
Created attachment 14648 [details]
Config file
Comment 4 Scott Russell 2001-04-04 11:31:06 EDT
Missing Info:

Testing build RC2 qa0401.

The two XFree86-4 config files attached are the same, the brow^H^H^H^H user just
messed up. You can ignore the second one.
Comment 5 Bill Nottingham 2001-04-04 12:36:42 EDT
Try running in 16bpp.
Comment 6 Scott Russell 2001-04-04 13:50:04 EDT
doh! I seem to recall this as a known limit on the voodoo cards now. I'll try
the 16bpp setting when I get home tonight and update this report.
Comment 7 Preston Brown 2001-04-04 16:22:43 EDT
Only works in 16 bit color modes.
Comment 8 Scott Russell 2001-04-04 22:37:07 EDT
Confirmed. I was just confused. Sorry for the traffic.

Note You need to log in before you can comment on or make changes to this bug.