Bug 348591 - Missing dependencies to run online-desktop-session properly
Missing dependencies to run online-desktop-session properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: online-desktop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 06:44 EDT by Sebastian Vahl
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 11:16:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2007-10-23 06:44:04 EDT
Description of problem/Use case:
A KDE User want to know what these shiny new "online-desktop" thing is. So he 
installs the package "online-desktop" through yum. All works fine but how to 
start it? He figures out (getting from 
http://fedoraproject.org/wiki/Releases/FeatureOnlineDesktop to 
http://online-desktop.org/wiki/Online_Desktop to 
http://live.gnome.org/OnlineDesktop/GetRunning) that he should login in a 
seperate session named "Online Desktop Demo". If he does so kdm would be 
showed up again after a few seconds.


Version-Release number of selected component (if applicable):
online-desktop-0.2.20-1.fc8

How reproducible:
ever

Steps to Reproduce:
1. Install from a KDE-Live-Image for F8 (or remove gnome-session, firefox, 
gnome-applets)
2. yum install online-desktop
3. Try to login into "Online Desktop Demo"
  
Actual results:
The online desktop would not start. Instead the login manager shows up again.

Expected results:
The online desktop should start.

Additional info:
The session isn't started because the needed package "gnome-session" is not 
installed. At least this one should be a direct dependency 
of "online-desktop".
But there are some more packages that should be needed:
gnome-applets: Otherwise one of the first messages would be that the mixer in 
gnome-panel couldn't be started.
firefox: Mugshot seems to be hardcoded to firefox as webbrowser. So firefox 
should also be a dependency or mugshot should use xdg-open/htmlview if 
possible (and this is maybe a seperate bug against mugshot).
Comment 1 Sebastian Vahl 2007-10-23 07:03:17 EDT
(In reply to comment #0)
> firefox: Mugshot seems to be hardcoded to firefox as webbrowser. So firefox 
> should also be a dependency or mugshot should use xdg-open/htmlview if 
> possible (and this is maybe a seperate bug against mugshot).

See also bug #348641

Comment 2 Colin Walters 2007-10-23 11:16:05 EDT
Fixed, thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.