Bug 348751 - Euro and Dollar keys not working on Acer Laptop
Euro and Dollar keys not working on Acer Laptop
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 09:42 EDT by Daniel Qarras
Modified: 2010-04-21 21:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 21:44:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 11227 None None None Never

  None (edit)
Description Daniel Qarras 2007-10-23 09:42:55 EDT
Description of problem:
Several Acer laptop models include special keys for Euro and Dollar signs. An
illustrating photo is available at
http://www.notebookreview.com/assets/5468.jpg. However, when pressing these keys
nothing happens.

Version-Release number of selected component (if applicable):
hal-info-20071011-1.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Open a terminal window
2. Press Euro or Dollar key
3. Notice how nothing is printed
  
Actual results:
No output.

Expected results:
Euro and Dollar signs output after a keypress.

Additional info:
Might need a kernel change (yes, there's no such key as KEY_EURO in the kernel).
Comment 2 Daniel Qarras 2009-10-23 17:27:40 EDT
Actually, after two years, this still does not work with Fedora 12 Beta - reopening.
Comment 3 Matěj Cepl 2009-11-05 12:11:29 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 4 Daniel Qarras 2009-11-06 18:17:27 EST
Yes this is still an issue but it seems that must wait for upstream:

http://bugs.freedesktop.org/show_bug.cgi?id=11227

CC'ing Peter who has provided the information there. Thanks.
Comment 5 Bug Zapper 2009-11-16 02:59:00 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Daniel Qarras 2010-04-20 17:07:34 EDT
Euro/Dollar keys still not working with F13ß.
Comment 8 Peter Hutterer 2010-04-21 21:44:46 EDT
Closing as UPSTREAM.

The limit to keycodes < 255 is hardcoded in the X protocol and while it could be worked around doing so is prohibitively expensive. The newly released XI2 (X server 1.7) supports 32 bit keycodes but it'll take a while until toolkits start adopting this new input framework. Meanwhile, these keys won't work until that happens.

Keeping this bug open is not really changing anything much, upstream is quite aware of the issue but the effort to implement it is rather high (and doesn't depend on xkeyboard-config or X.Org alone). So I think deferring this is the best (well, not "best" but "right") resolution here.

Note You need to log in before you can comment on or make changes to this bug.