Bug 349731 - 64-bit select() descriptor bug
64-bit select() descriptor bug
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcl (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 18:50 EDT by Chris Schanzle
Modified: 2009-04-14 02:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 10:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Schanzle 2007-10-23 18:50:40 EDT
Description of problem:

tcl-8.4.13-3.fc6 on RHEL 5 (.0) on x86_64, the number of file descriptors
available to select() is limited to < 32 due to a bug, since fixed.  Now that
we're using 16-core systems, we're running out of descriptors with our parallel
code.

Version-Release number of selected component (if applicable):
tcl-8.4.13-3.fc6.x86_64

How reproducible:
always

Additional info:
This bug is definitely fixed (verified with local build) in Tcl 8.4.16 and we
also believe in 8.4.15.

Discussion of core bug:
http://sourceforge.net/tracker/index.php?func=detail&aid=1602208&group_id=10894&atid=110894

Thanks in advance for having a look.
Comment 1 Marcela Mašláňová 2007-10-24 03:40:54 EDT
I think the solution: bit = (fd_mask)1 << (fd%(NBBY*sizeof(fd_mask))); would be
ok also the last version of tcl8.5b fix it in the same way.

Why are you using fc6 build of tcl for RHEL-5? There is the same version of tcl.
If you want fix for this problem in RHEL-5, please contact your support.
Comment 2 Chris Schanzle 2007-10-24 10:29:35 EDT
Sorry, it's a CentOS 5 box, trying to report to "upstream" the issue.  Is there
a more appropriate process you can point me to?  Opened bug with CentOS.  
Thanks, -c
Comment 3 Marcela Mašláňová 2007-10-24 10:41:55 EDT
I thought so ;-)
I fixed it in fedora7, in the tcl upstream is it fix in higher version. For
centos you should open the bug yourself ;-) on their bugzilla or whatever they have.
Comment 4 Marcela Mašláňová 2007-10-24 10:44:32 EDT
This problem is resolved in the next release of Red Hat Enterprise Linux. Red
Hat does not currently plan to provide a resolution for this in a Red Hat
Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects. 
Comment 5 Ralph Angenendt 2007-10-24 12:28:54 EDT
Not wanting to reopen the bug, but: RHEL is shipping tcl with an fc6 tag in the
version. So he's not running an fc6 version on his machine, but the version from
RHEL (or, okay, the version we rebuilt from the SRPM on ftp.redhat.com):

lftp ftp.redhat.com:/pub/redhat/linux/enterprise/5Server/en/os/SRPMS> ls tcl-*
-rw-r--r--    2 ftp      ftp       6795594 Jan 18  2007 tcl-8.4.13-3.fc6.src.rpm
Comment 6 Marcela Mašláňová 2007-10-25 02:55:24 EDT
Hm you are right, it's fc6. But as was told in upstream comment, the function
where the problem occurs, was written for testing purposes. So it has a low
priority.
Comment 7 Chris Schanzle 2007-10-25 13:20:37 EDT
Uh, no.  :-)  The fixed routine is not just for testing purposes - it is called
by TcpInputProc().  The original reporter said it was hanging his HA monitoring
daemon, and we are seeing it in our (unfortunately complex, event driven)
parallel code.

We understand you want stability.  But understand we want already solved fixes
made available too.

I'll get a RHEL license and open a case against this issue.
Comment 8 Chris Schanzle 2007-10-25 13:22:39 EDT
Is this really slated to be fixed in RHEL 5.1 or was that just boilerplate?  Tcl
is not one of the packages listed as being updated for RHEL 5.1 beta. 
https://www.redhat.com/archives/rhelv5-beta-list/2007-July/msg00000.html
Comment 9 Marcela Mašláňová 2007-10-26 02:32:28 EDT
It's too late for fix in RHEL-5.1. Maybe in 5.2, but I'm for next release.
Comment 10 Chris Schanzle 2009-04-10 17:08:23 EDT
Hmm, tcl version unchanged in 5.3 either, so does "nextrelease" mean 6.0?
Comment 11 Marcela Mašláňová 2009-04-14 02:22:13 EDT
Yes, I meant 6.0.

Note You need to log in before you can comment on or make changes to this bug.