Bug 349821 - need way to set clock to localtime virt-manager
need way to set clock to localtime virt-manager
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On: 245203
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 21:35 EDT by Andrew Bartlett
Modified: 2008-01-22 10:32 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.300.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:32:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Virt manager log (126.07 KB, text/plain)
2007-10-23 23:36 EDT, Andrew Bartlett
no flags Details

  None (edit)
Description Andrew Bartlett 2007-10-23 21:35:41 EDT
Description of problem:
Bug 245203 fixed the libvirt side of this problem, but virt-manager needs to set
this attribute during the install of windows guests.  (And allow it to be
modified later). 

Version-Release number of selected component (if applicable):

virt-manager-0.5.2-2.fc8
libvirt-0.3.3-2.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Install windows guest with virt-manager
2. Look at clock
3. 
  
Actual results:
Time in UTC

Expected results:
Local time

Additional info:
Isn't this exactly the kind of thing the guest OS selection is meant to be for?
Comment 1 Daniel Berrange 2007-10-23 23:21:55 EDT
Yes, if you select the 'Windows' guest OS type during the installation wizard it
is supposed to automatically configure the clock to 'localtime'. Can you confirm
what  OS type you selected, and provide the /root/.virt-manager/virt-manager.log
file which will tell us what clock source was configured for the guest.
Comment 2 Andrew Bartlett 2007-10-23 23:36:10 EDT
Created attachment 235831 [details]
Virt manager log

This log shows that I selected windows XP (which I did).
Comment 3 Daniel Berrange 2007-10-23 23:46:04 EDT
Looks like virt-inst library isn't configuring the clock source correctly. It is
adding the USB tablet for sane Windows mouse, but not setting clock at all.
Comment 4 Cole Robinson 2007-12-17 15:12:51 EST
A fix was applied for this:
http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=325a56861208

Specifying you are installing a windows guest should set 'localtime'
automatically. I'll close this bug when a new release is pushed out. Thanks!
Comment 5 Fedora Update System 2008-01-11 17:27:58 EST
python-virtinst-0.300.2-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'
Comment 6 Andrew Bartlett 2008-01-20 20:06:28 EST
Localtime is now detected on a new WinXP install.  Thanks!
Comment 7 Fedora Update System 2008-01-22 10:32:28 EST
python-virtinst-0.300.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.