Bug 349841 - gnome-devel-docs - GNOME developer documentation
gnome-devel-docs - GNOME developer documentation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 21:57 EDT by Matthias Clasen
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 22:23:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rstrode: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2007-10-23 21:57:43 EDT
Spec: http://people.redhat.com/mclasen/gnome-devel-docs.spec
SRPM: http://people.redhat.com/mclasen/gnome-devel-docs-2.20.0-1.fc8.src.rpm

Description:

This package contains documents which are targeted for GNOME developers.
It contains e.g. the Human Interface Guidelines, the Integration Guide
and the Platform Overview.

Known issues:

COPYING is GPL, docs are under GFDL.
Comment 1 Matthias Clasen 2007-10-23 21:59:51 EDT
License confusion is filed as: http://bugzilla.gnome.org/show_bug.cgi?id=486835
Comment 2 Ray Strode [halfline] 2007-10-23 23:38:07 EDT
So you have:

# no translations currently, but there should be eventually
%find_lang %{name} --with-gnome || :

and then:

%files -f %{name}.lang

but if find_lang fails then %{name}.lang won't exist, yea?
Comment 3 Matthias Clasen 2007-10-23 23:52:57 EDT
hmm, I tried to copy your trick, but I seem to have failed. but actually, 
there are already translations, since C counts too.
Comment 4 Ray Strode [halfline] 2007-10-24 00:16:44 EDT
%description 
This package contains documents which are targeted for GNOME developers.
It contains e.g. the Human Interface Guidelines, the Integration Guide
and the Platform Overview.

^^ e.g. should have commas on each side of it
Comment 5 Ray Strode [halfline] 2007-10-24 00:18:36 EDT
i guess you should either add the touch after the ||  or just remove the || :

Comment 6 Ray Strode [halfline] 2007-10-24 00:19:32 EDT
fix those issues and you're set to go. rpmlint seems fine and it builds in mock.
Comment 7 Matthias Clasen 2007-10-24 15:42:04 EDT
Ok, I'll fix that.

New Package CVS Request
=======================
Package Name: gnome-devel-docs
Short Description: GNOME developer documentation
Owners: mclasen@redhat.com
Branches:
Cvsextras Commits: yes
Comment 8 Kevin Fenzi 2007-10-24 20:58:12 EDT
cvs done.

Note You need to log in before you can comment on or make changes to this bug.