Bug 349861 - nspluginwrappers requires not glib but glib2
nspluginwrappers requires not glib but glib2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-23 22:44 EDT by Takanori MATSUURA
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 05:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Takanori MATSUURA 2007-10-23 22:44:43 EDT
There is glib requirement in the spec file. But nspluginwrapper requires glib2.

So we should replace "Requires: glib" to "BuildRequires: glib2-devel" in the
spec file.
Comment 1 Martin Stransky 2007-10-24 04:10:59 EDT
really? It builds in mock without any problem so I looks like all deps are ok....
Comment 2 Takanori MATSUURA 2007-10-24 04:43:51 EDT
There is no libglib-1.2.so*,  libgmodule-1.2.so*, or libgthread-1.2.so*
dependency at the following.

$ rpm -qpR nspluginwrapper-0.9.91.5-7.fc8.x86_64.rpm
/bin/sh
/bin/sh
/bin/sh
/usr/bin/linux32
gecko-libs
libX11.so.6()(64bit)
libXt.so.6()(64bit)
libatk-1.0.so.0()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.7)(64bit)
libcairo.so.2()(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libgdk-x11-2.0.so.0()(64bit)
libgdk_pixbuf-2.0.so.0()(64bit)
libglib-2.0.so.0()(64bit)
libgmodule-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libgtk-x11-2.0.so.0()(64bit)
libnspr4.so()(64bit)
libpango-1.0.so.0()(64bit)
libpangocairo-1.0.so.0()(64bit)
libplc4.so()(64bit)
libplds4.so()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rtld(GNU_HASH)
Comment 3 Martin Stransky 2007-10-24 05:04:10 EDT
okay, added to nspluginwrapper-0.9.91.5-10.fc9.

Note You need to log in before you can comment on or make changes to this bug.