Bug 34993 - kernel source does not compile.
Summary: kernel source does not compile.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-06 11:46 UTC by Knut J BJuland
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-06 14:29:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file of compilg make module (1.31 KB, text/plain)
2001-04-06 14:16 UTC, Knut J BJuland
no flags Details

Description Knut J BJuland 2001-04-06 11:46:21 UTC
I copied kernel-i686.config into /usr/src/linux-2.4 from configs in
/usr/src/linux-2.4. Gcc-2.96-80 was used, and in /usr/src/linux is
linux-2.4.3-ac3 which I also compiled with gcc-2.96-80. I am unable to
compile kernel-source-2.4.2-0.1.49. I did this recompiling because I would
like to use pIII kernel.

Comment 1 Arjan van de Ven 2001-04-06 14:05:56 UTC
Can you please specify 
1) What commands you used to recompile your kernel
2) Give the error-message !!!!!

Comment 2 Knut J BJuland 2001-04-06 14:16:16 UTC
Created attachment 14783 [details]
log file of compilg make module

Comment 3 Knut J BJuland 2001-04-06 14:18:05 UTC
I used make dep bzimage modules. used make oldconfig to migrate data from
configs/kernel-2.4.2.i686. It fails when using make modules make bzImage works
fine.

Comment 4 Arjan van de Ven 2001-04-06 14:19:29 UTC
I fail to see the error in the make modules output
maybe there was an error before you started the output....
could you give the full log?

Comment 5 Knut J BJuland 2001-04-06 14:29:35 UTC
make[ 2]: *** loop.o error 1
make 2  leaving /usr/src/linux-2.4/drivers/block
make[1] ***[_modsubdir_block] Error 2
make[1] ** [_mod_drivers] Error 2
make: *** [_mod_drivers] Error 2,

it then stops to compile, make bzimage works fine but nor make modules.

Comment 6 Knut J BJuland 2001-04-06 15:28:57 UTC
I mange to compile it under linux-2.4.3-ac3, I had to reinstalled it to get it
to compile.

Comment 7 Sammy 2001-04-06 16:30:11 UTC
Did you say "make mrproper" at the beginning?


Comment 8 Knut J BJuland 2001-04-06 20:50:10 UTC
no, make oldconfig but  I used now make mrproper, then copied config from
configs, make oldconfig, make dep bzImage modules modules_install.

I used make oldconfig to use your config for i686 kernel.


Note You need to log in before you can comment on or make changes to this bug.