Bug 349971 - Unuseable screen resolution in anaconda. May be X problem.
Unuseable screen resolution in anaconda. May be X problem.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 00:29 EDT by charles harris
Modified: 2009-01-09 02:20 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:20:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
f8test3 xorg.conf file (564 bytes, application/octet-stream)
2007-10-26 03:02 EDT, charles harris
no flags Details
f8test3 xorg.conf file (564 bytes, text/plain)
2007-10-26 03:03 EDT, charles harris
no flags Details
Xorg.0.log from successful boot (53.03 KB, text/plain)
2007-10-27 01:57 EDT, charles harris
no flags Details
Bad boot (52.68 KB, text/plain)
2007-10-28 16:50 EDT, charles harris
no flags Details
Good boot. (52.68 KB, application/octet-stream)
2007-10-28 16:51 EDT, charles harris
no flags Details

  None (edit)
Description charles harris 2007-10-24 00:29:49 EDT
Description of problem:

When anaconda brings up X the resulting screen is about 3"x5" and totally
unreadable. Because the live disk segfaults during boot I can't check if this
problem is present there also. F7 works fine on this hardware.

Hardware:

GeForce 8600 GT
DELL 2405FPW

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from the iso image.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matěj Cepl 2007-10-25 06:47:46 EDT
Have you tried to install in text mode (write "linux text" on the initial
command prompt)? If you managed to do that, do you have X running?
/var/log/Xorg.0.log and /etc/X11/xorg.conf attached to this bug as separate
uncompressed attachments would be very helpful. Thank you.
Comment 2 charles harris 2007-10-26 03:02:09 EDT
Created attachment 238511 [details]
f8test3 xorg.conf file
Comment 3 charles harris 2007-10-26 03:03:31 EDT
Created attachment 238521 [details]
f8test3 xorg.conf file
Comment 4 charles harris 2007-10-26 04:05:10 EDT
The text mode install works -- well, it wants to install grub on my MBR, tsk,
tsk -- but it won't boot on account of bug #252443, so all I have is the
xorg.conf file and it doesn't look very useful. F7 works fine on this system,
although I haven't tried the nv driver recently. I think there was a message
about an unrecognized device when anaconda did the video probe, so maybe the nv
driver has changed.

I'll try moving a different kernel over to fc8 and see if I can get it to boot.
Comment 5 charles harris 2007-10-27 01:50:53 EDT
OK, fc8 booted with 2.6.23.1 patched with the cfs updates. X came up as expected
after I edited inittab and turned off SELinux (which tossed a bunch of
complaints but allowed X to run). I've attached Xorg.0.log.
Comment 6 charles harris 2007-10-27 01:57:05 EDT
Created attachment 240201 [details]
Xorg.0.log from successful boot
Comment 7 charles harris 2007-10-28 16:47:04 EDT
I still get occasional X failures, my screen comes up black when gdm starts and
displays the error message "can not display this mode". I will attach the
Xorg.0.log files from both a successful and failed boot. The differences are
small, but maybe they will tell you something.
Comment 8 charles harris 2007-10-28 16:50:19 EDT
Created attachment 240971 [details]
Bad boot

I pushed the reset button here after waiting a bit. So I hope this log is
valid.
Comment 9 charles harris 2007-10-28 16:51:19 EDT
Created attachment 240981 [details]
Good boot.
Comment 10 charles harris 2008-05-06 23:49:15 EDT
This problem is replicated in f9-preview, except the resolution is usable. I
have a 1920x1200 screen and it looks fine after install, but during install the
screen is about 480 pixels high and expanded to the full screen width.
Comment 11 Bug Zapper 2008-11-26 03:05:23 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2009-01-09 02:20:24 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.