Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 350011 - Bug report appeared without any noticeable problem
Bug report appeared without any noticeable problem
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 00:58 EDT by John O Richardson Jr
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 09:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John O Richardson Jr 2007-10-24 00:58:20 EDT
Description of problem:I don't know what the problem is.  A pop-window said an
error had occurred and to send the information to Bugzilla.
Component: pirut
Summary: TB8f5a3431 yumRepo.py:749:_getRepoXML:RepoError: Cannot retrieve
repository metadata (repomd.xml) for repository: freshrpms. Please verify its
path and try again

Traceback (most recent call last):
  File "/usr/sbin/pup", line 650, in <module>
    main()
  File "/usr/sbin/pup", line 643, in main
    pup = PackageUpdater(not options.autoapply, options.config)
  File "/usr/sbin/pup", line 88, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 124, in __init__
    self.reset()
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 223, in reset
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 521, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
_check_db_version
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 753, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 749, in _getRepoXML
    raise Errors.RepoError, (msg)
RepoError: Cannot retrieve repository metadata (repomd.xml) for repository:
freshrpms. Please verify its path and try again

Local variables in innermost frame:
msg: Cannot retrieve repository metadata (repomd.xml) for repository: freshrpms.
Please verify its path and try again
self: freshrpms
e: Cannot find a valid baseurl for repo: freshrpms


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:Guys, let me know if a newbie like me should send in these
reports.  If they are useless, I won't send anymore.  Thanks, John  P.S., I am
not going to look in the bug reports, because I don't know what I am looking
for.  It won't hurt my feelings if you tell me not to send reports. By the way I
am using a Bagvapp version on Vmware Player.
Comment 1 Jeremy Katz 2007-11-19 13:57:17 EST
Does this happen reliably?
Comment 2 John O Richardson Jr 2007-11-19 22:15:16 EST
(In reply to comment #1)
> Does this happen reliably?
I don't know what that means.  I was using Fedora 7 Test 3 when I was instructed
to send the bug report.  Because the test version was not as reliable as the
Fedora 7, I deleted it and no longer use it.  I have no further information to
give to Bugzilla about Fedora 7 Test 3.

Comment 3 Jeremy Katz 2007-11-20 09:59:56 EST
Fedora 7 test 3?  That's a preview release from before Fedora 7.  

Note You need to log in before you can comment on or make changes to this bug.