Bug 350071 - kooka requires ocrad (or gocr) for OCR but it is not available
Summary: kooka requires ocrad (or gocr) for OCR but it is not available
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdegraphics   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-24 07:08 UTC by David Fraser
Modified: 2008-01-30 11:01 UTC (History)
1 user (show)

Fixed In Version: kdegraphics-3_5_8-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 11:01:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Fraser 2007-10-24 07:08:36 UTC
Description of problem:
kooka, the scanning and OCR program included in kdegraphics, uses a program
called ocrad for OCR. However ocrad is not available in the Fedora repository,
and kdegraphics therefore doesn't depend on it.

Version-Release number of selected component (if applicable):
kdegraphics-3.5.7-2.fc7

How reproducible:
Consistently

Steps to Reproduce:
1. Start Kooka (KDE menu -> graphics -> Scan & OCR program (Kooka))
2. Open an Image
3. Click Image->OCR Image
  
Actual results:
Dialog appears saying "The path to the ocrad binary is not configured yet"

Expected results:
OCR analysis of the image

Additional info:
There is an ocrad package available in the dag repository:
http://dag.wieers.com/rpm/packages/ocrad/
Building from this spec file produced a clean ocrad package, after installation
of which Kooka was able to OCR successfully.

Kooka can also use gocr which is available in the Fedora repository, but because
kdegraphics doesn't depend on it it is not installed automatically; also Kooka
is not configured to use it by default (this can be changed in the settings page).

Comment 1 Ngo Than 2008-01-30 11:01:59 UTC
it's fixed in kdegraphics-3_5_8-8_fc7(f8). Thanks for your report.



Note You need to log in before you can comment on or make changes to this bug.