Bug 350091 - 2.6.23.1-4.fc7: kernel BUG at fs/inode.c:247
2.6.23.1-4.fc7: kernel BUG at fs/inode.c:247
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 03:51 EDT by Pekka Savola
Modified: 2008-01-21 02:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.8-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 02:12:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2007-10-24 03:51:50 EDT
Description of problem:
After upgrading to 2.6.23 based kernel, I've started seeing the following oops.  

This has happened twice when plugging in or out an USB WLAN or RS-232 adapter so
it could be USB related.

Version-Release number of selected component (if applicable):
2.6.23.1-4.fc7

This seems almost identical to
https://bugzilla.redhat.com/show_bug.cgi?id=176696 so these are likely related.
Comment 1 Pekka Savola 2007-10-24 03:52:16 EDT
Oct 24 10:33:22 lapps kernel: kernel BUG at fs/inode.c:247!
Oct 24 10:33:22 lapps kernel: invalid opcode: 0000 [#1]
Oct 24 10:33:22 lapps kernel: SMP
Oct 24 10:33:22 lapps kernel: Modules linked in: uhci_hcd arc4 ecb blkcipher
rc80211_simple zd1211rw_mac80211 mac80211 cfg80211 cpufreq_ondemand autofs4 hidp
rfcomm l2cap bluetooth sunrpc dm_mirror dm_multipath dm_mod sbs bay ipv6
snd_intel8x0m snd_intel8x0 snd_ac97_codec ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss firewire_ohci
snd_mixer_oss ac firewire_core battery nsc_ircc video snd_pcm parport_pc irda
e100 crc_itu_t mct_u232 output snd_timer parport crc_ccitt mii button iTCO_wdt
i2c_i801 snd usbserial iTCO_vendor_support floppy i2c_core soundcore
snd_page_alloc sg ata_generic ata_piix libata sd_mod scsi_mod ext3 jbd mbcache
ehci_hcd ohci_hcd
Oct 24 10:33:22 lapps kernel: CPU:    0
Oct 24 10:33:22 lapps kernel: EIP:    0060:[<c0491502>]    Not tainted VLI
Oct 24 10:33:22 lapps kernel: EFLAGS: 00210206   (2.6.23.1-4.fc7 #1)
Oct 24 10:33:22 lapps kernel: EIP is at clear_inode+0x2b/0x11a
Oct 24 10:33:22 lapps kernel: eax: c41ff178   ebx: c41ff178   ecx: ffffffff  
edx: c613c000
Oct 24 10:33:22 lapps kernel: esi: c04aec0c   edi: c3dcc3b8   ebp: c41ff178  
esp: c613cf34
Oct 24 10:33:22 lapps kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
Oct 24 10:33:22 lapps kernel: Process xfce4-battery-p (pid: 2841, ti=c613c000
task=c9350c20 task.ti=c613c000)
Oct 24 10:33:22 lapps kernel: Stack: c04aec44 c41ff178 c04aec0c c0491692
c41ff178 c3dcc3b8 c0490e25 c3dcc3b8
Oct 24 10:33:22 lapps kernel:        c048f269 c3dcc3b8 c3fd3e60 c048fd2c
00000010 c0481c4e 00000000 00000000
Oct 24 10:33:22 lapps kernel:        c3dcc3b8 cf670480 c41ff178 c3fd3e60
c8e48480 00000000 c613c000 c047f541
Oct 24 10:33:22 lapps kernel: Call Trace:
Oct 24 10:33:22 lapps kernel:  [<c04aec44>] proc_delete_inode+0x38/0x41
Oct 24 10:33:22 lapps kernel:  [<c04aec0c>] proc_delete_inode+0x0/0x41
Oct 24 10:33:22 lapps kernel:  [<c0491692>] generic_delete_inode+0xa1/0x107
Oct 24 10:33:22 lapps kernel:  [<c0490e25>] iput+0x5f/0x61
Oct 24 10:33:22 lapps kernel:  [<c048f269>] d_kill+0x19/0x32
Oct 24 10:33:22 lapps kernel:  [<c048fd2c>] dput+0xd0/0xd7
Oct 24 10:33:22 lapps kernel:  [<c0481c4e>] __fput+0x147/0x171
Oct 24 10:33:22 lapps kernel:  [<c047f541>] filp_close+0x51/0x58
Oct 24 10:33:23 lapps kernel:  [<c04805be>] sys_close+0x6e/0xa5
Oct 24 10:33:23 lapps kernel:  [<c040518a>] syscall_call+0x7/0xb
Oct 24 10:33:23 lapps kernel:  =======================
Oct 24 10:33:23 lapps kernel: Code: 56 ba f4 00 00 00 53 89 c3 83 ec 04 b8 b2 8e
6b c0 e8 ec 48 f9 ff e8 4e ab 18 00 89 d8 e8 1f d9 00 00 83 bb d8 00 00 00 00 74
04 <0f> 0b eb fe 8b 83 38 01 00 00 a8 10 75 04 0f 0b eb fe a8 20 74
Oct 24 10:33:23 lapps kernel: EIP: [<c0491502>] clear_inode+0x2b/0x11a SS:ESP
0068:c613cf34
Comment 2 Christopher Brown 2008-01-15 21:55:16 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 3 Pekka Savola 2008-01-21 02:12:47 EST
I do not recall seeing this since October, and I can't find any of this in the
logs since.  Maybe it has been fixed.  As there has been no other activity on
this, I'll close the report.

Note You need to log in before you can comment on or make changes to this bug.