Bug 350191 - TAHI--Can not observe a Neighbor Solicitation packet in some scenarioes
TAHI--Can not observe a Neighbor Solicitation packet in some scenarioes
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Graf
Martin Jenner
:
Depends On:
Blocks: 253764
  Show dependency treegraph
 
Reported: 2007-10-24 05:40 EDT by Zhiyong Wu
Modified: 2014-06-18 04:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 10:42:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhiyong Wu 2007-10-24 05:40:35 EDT
Description of problem:
  
  When we have some tests about the following scenaria (1)"Test v6LC.2.3.3: 

Redirected On-link: Invalid" and (2)"Redirected to Alternate Router: Valid",some  

tests fails because of not observing a Neighbor Solicitation packet. 

Version-Release number of selected component (if applicable):

  kernel-2.6.18-43.el5

Software Environment:   
  
  Testee(NUT):   
    RHEL5 
    Kernel:2.6.18-43.el5 
   
  Tester(TN):   
    FreeBSD6.2 
   
How reproducible:

  every time

Steps to Reproduce:

  1. Configure TAHI test environment.     
  2. Run the TAHI test suite     
  3. After the test completes, check for the results
  
Actual results:

  TN can not observe a Neighbor Solicitation packet.

Expected results:

  TN should observe a Neighbor Solicitation packet.

Additional info:
 
For more information,please refer to

http://focus.brisbane.redhat.com/~zwu/CoreProtocol/20071024/Self_Test_1-4-8_p2_host/nd.p2/index.html

(1) 187	Part H: ICMPv6 length is less than 40 Octets

(2) 188	Part I: Option has Length Zero

(3) 189	Part A: dst=link-local, w/o TLL, w/o Redirected Header

(4) 190	Part B: dst=link-local, w/o TLL, w/  Redirected Header

Note You need to log in before you can comment on or make changes to this bug.