Bug 35036 - up2date installation of 2.4.2-0.1.49 kernel failed
up2date installation of 2.4.2-0.1.49 kernel failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 11:47 EDT by adler
Modified: 2015-01-07 18:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 16:09:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
original lilo.conf file which up2date saw when up2dating the kernel (346 bytes, text/plain)
2001-04-06 11:52 EDT, adler
no flags Details

  None (edit)
Description adler 2001-04-06 11:47:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.49smp i686)


When the up2date was done doing its rpm -ivh's, a window poped up saying
that the test version of lilo failed

Reproducible: Didn't try
Steps to Reproduce:
1.run up2date
2.request that kernel gets updated
3.watch error message window pop up
	

The problem is that there was no output or log or anything which I could
determine why the test lilo failed. My lilo file, which I'll attach is
*very* generic. There should have been no problem with it. One bit which is
strange on my system, and I don't know if I should bugzilla this is that I
have two entries for the same rpm package, specifically the kernel rpms. I
caused this in my rash of rpm'ing one day and I installed the kernel rpm
twice with a --force. I can't seem to get rid of it now. Here look:

[adler@ssadler adler]$ rpm -qa | grep kernel 
kernel-headers-2.4.2-0.1.49
kernel-source-2.4.2-0.1.49
kernelcfg-0.6-10
kernel-doc-2.4.2-0.1.49
kernel-pcmcia-cs-3.1.24-2
kernel-2.4.2-0.1.28
kernel-enterprise-2.4.2-0.1.28
kernel-BOOT-2.4.2-0.1.49
kernel-smp-2.4.2-0.1.49     <<<<----?????
kernel-smp-2.4.2-0.1.49     <<<<----?????
kernel-2.4.2-0.1.49         <<<<----?????
kernel-2.4.2-0.1.49         <<<<----?????
kernel-BOOT-2.4.2-0.1.28
kernel-enterprise-2.4.2-0.1.49
kernel-smp-2.4.2-0.1.28

What I've done is modified the lilo.conf file by hand, I've run lilo and
I'm now runnig the new kernel.
Comment 1 adler 2001-04-06 11:52:23 EDT
Created attachment 14804 [details]
original lilo.conf file which up2date saw when up2dating the kernel
Comment 2 Adrian Likins 2001-04-06 12:01:28 EDT
multiple versions of kernels packages is expected. Multiple instances
of the same kernel package (ie, the two kernel-smp-2.4.2-0.1.49 
 you show) is not. 

In theory, thats not supposed to happen ;-> Of course, in
practice, it does happen on occasion. More than likely one
is a 386 kernel, and one is a 686 kernel. Can you try:

     rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" | grep kernel

I'll attempt to duplicate this. 

I'm assuming that up2date gave the error message about lilo failing, but
left the system in a bootable state? Making sure we successfully install
the new kernels is important, but making sure we handle failures gracefully
in this case is probabaly even more important.
Comment 3 adler 2001-04-06 17:47:24 EDT
The output you requested. Looks like I do have multple
architectures installed. How does one remove the
unwanted architecture?

Steve.

[root@ssadler /root]# rpm -qa --queryformat
"%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" | grep kernel
kernel-headers-2.4.2-0.1.49.i386
kernel-source-2.4.2-0.1.49.i386
kernelcfg-0.6-10.i386
kernel-doc-2.4.2-0.1.49.i386
kernel-pcmcia-cs-3.1.24-2.i386
kernel-2.4.2-0.1.28.i686
kernel-enterprise-2.4.2-0.1.28.i686
kernel-BOOT-2.4.2-0.1.49.i386
kernel-smp-2.4.2-0.1.49.i686
kernel-smp-2.4.2-0.1.49.i586
kernel-2.4.2-0.1.49.i386
kernel-2.4.2-0.1.49.i686
kernel-BOOT-2.4.2-0.1.28.i386
kernel-enterprise-2.4.2-0.1.49.i686
kernel-smp-2.4.2-0.1.28.i686
Comment 4 Adrian Likins 2002-03-26 17:57:48 EST
I belive all the bugs related to multiple kernels should
be well shaken out at this point, so closing this bug.

Note You need to log in before you can comment on or make changes to this bug.