Bug 35060 - fsck stage does not wait for all disks to finish
fsck stage does not wait for all disks to finish
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 15:59 EDT by Michael Meissner
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 04:24:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Meissner 2001-04-06 15:59:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3 i686)


I have 15 partitions on my system, spread out over 6 scsi disks, and 1 ide
disk:

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda5             2.9G  2.1G  707M  75% /
/dev/hda6              30M   17M   12M  58% /alt-boot
/dev/sdb1              30M   11M   18M  36% /alt-boot2
/dev/hda8             2.9G  1.6G  1.1G  59% /alt-root
/dev/sdb2             1.9G  1.6G  320M  83% /alt-root2
/dev/hda9              45G   39G  5.4G  88% /backup
/dev/sda1              30M   20M  9.1M  69% /boot
/dev/sda7             5.4G  4.5G  699M  87% /home
/dev/sdb6             6.3G  4.9G  1.2G  79% /key
/dev/sdf2             3.5G  1.8G  1.5G  54% /shaft
/dev/sde1             4.1G  3.3G  685M  83% /cam
/dev/sdd1             3.9G  3.2G  569M  86% /oil
/dev/sdf1             656M   20k  622M   1% /cdtmp
/dev/sdc3             7.7G  4.9G  2.3G  68% /crank
/dev/sdc1             8.2G  6.0G  1.8G  76% /gear

I just had a hang, and rebooted.  From the log messages, the fscks were
started in parallel as expected, but /gear and /crank (/dev/sdc1 and
/dev/sdc3) did not finish by the time the netfs script was run.  This
resulted in /crank and /gear being mounted at the same time fsck was still
working on the disk. 

Reproducible: Sometimes
Steps to Reproduce:
1. Have many large disk partitions spread out over several disks
2. Reboot the system without unmounting the disks
3. Watch the log messages
4. Log on and verify that disks are mounted while being fixed.
	

Actual Results:  Potential data corruption if I hadn't caught it and rerun
fsck.

Expected Results:  It is a very serious error for /etc/rc.d/rc.sysinit to
proceed while any disk is still being fixed up.  Other startup scripts
might depend on disks being mounted, and there certainly seems to be a
large risk that a disk might be trashed while it is mounted and fsck is
still working on the partition.
Comment 1 Florian La Roche 2001-05-16 04:24:52 EDT
Does this still happen with e2fsprogs-1.20-0.01 from
http://people.redhat.com/laroche/e2*?
What is in /etc/fstab for these partitions that are mounted in the background?
Comment 2 Florian La Roche 2002-08-02 04:19:25 EDT
I don't see how this could happen. Please re-open if this is still a problem.

Thanks,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.