Bug 350811 - (firefox-2.0.0.8-deps) Gecko-libs dependency blocking firefox update
Gecko-libs dependency blocking firefox update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 351161 351281 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 13:04 EDT by Matt Thompson
Modified: 2007-11-30 17:12 EST (History)
9 users (show)

See Also:
Fixed In Version: galeon-2.0.3-12.fc7, epiphany-2.18.3-3.fc7, devhelp-0.13-10.fc7, yelp-2.18.1-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 04:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Thompson 2007-10-24 13:04:45 EDT
Description of problem:
Trying to update firefox to 2.0.0.8 leads to a yum conflict.

Version-Release number of selected component (if applicable):
firefox 2.0.0.8

How reproducible:
Always

Steps to Reproduce:
1. yum update (with only firefox packages)
2.
3.
  
Actual results:
-- root@oxygen:~ --
# yum check-update 
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile

firefox.i386                             2.0.0.8-1.fc7          updates         
firefox.x86_64                           2.0.0.8-1.fc7          updates         
firefox-devel.i386                       2.0.0.8-1.fc7          updates         
firefox-devel.x86_64                     2.0.0.8-1.fc7          updates         
-- root@oxygen:~ --
# yum update 
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package firefox-devel.i386 0:2.0.0.8-1.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: devhelp
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: devhelp
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: yelp
---> Package firefox.i386 0:2.0.0.8-1.fc7 set to be updated
---> Package firefox-devel.x86_64 0:2.0.0.8-1.fc7 set to be updated
---> Package firefox.x86_64 0:2.0.0.8-1.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: devhelp
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: devhelp
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: yelp
--> Finished Dependency Resolution
Error: Missing Dependency: gecko-libs = 1.8.1.5 is needed by package yelp
Error: Missing Dependency: gecko-libs = 1.8.1.5 is needed by package devhelp


Expected results:
Actually updating firefox.

Additional info:
I didn't know if this was a firefox, yum, or yelp/devhelp bug.
Comment 1 Matt Thompson 2007-10-24 13:10:11 EDT
Also, I failed to mention that I have run "yum clean all" and repeated the steps
with no change in the error.
Comment 2 Peter van Hooft 2007-10-24 15:41:22 EDT
Both yelp and devhelp depend on:
        libgtkembedmoz.so => /usr/lib/firefox-2.0.0.5/libgtkembedmoz.so (0x001ab000)
        libxpcom.so => /usr/lib/firefox-2.0.0.5/libxpcom.so (0x0013f000)
        libxpcom_core.so => /usr/lib/firefox-2.0.0.5/libxpcom_core.so (0x005a7000)
<pc67140121-[~]>107 % ldd `which devhelp`|grep firefox
        libgtkembedmoz.so => /usr/lib/firefox-2.0.0.5/libgtkembedmoz.so (0x001ab000)
        libxpcom.so => /usr/lib/firefox-2.0.0.5/libxpcom.so (0x00189000)
        libxpcom_core.so => /usr/lib/firefox-2.0.0.8/libxpcom_core.so (0x002c2000)
Comment 3 Matthew Barnes 2007-10-24 18:35:48 EDT
*** Bug 351161 has been marked as a duplicate of this bug. ***
Comment 4 Pitam 2007-10-24 23:58:38 EDT
gecko-libs is provided by Firefox. uninstall and then reinstall firefox. It will
be solved (temporary solution till a fix is released)

# rpm --erase firefox --nodeps
.
# yum install firefox
Comment 5 Jacek Piskozub 2007-10-25 01:37:39 EDT
A new yelp has been released to fix this problem. 

From yelp changelog:

* Wed Oct 24 2007 Matthew Barnes <mbarnes@redhat.com> - 2.14.3-5.fc7
- Rebuild against firefox-2.0.0.8.
* Thu Jul 19 2007 Matthew Barnes <mbarnes@redhat.com> - 2.14.3-4.fc7
- Rebuild against firefox-2.0.0.5.

The update works with me now. I suggest closing the bug.
Comment 6 Matěj Cepl 2007-10-25 04:10:50 EDT
*** Bug 351281 has been marked as a duplicate of this bug. ***
Comment 7 Matěj Cepl 2007-10-25 04:19:56 EDT
*** Bug 351091 has been marked as a duplicate of this bug. ***
Comment 8 Matěj Cepl 2007-10-25 04:22:00 EDT
galeon-2.0.3-12.fc7, epiphany-2.18.3-3.fc7, devhelp-0.13-10.fc7, and
yelp-2.18.1-6.fc7 are in f7-updates-testing to fix this issue.
Comment 9 Scott Dowdle 2007-10-26 21:26:28 EDT
(In reply to comment #4)
> gecko-libs is provided by Firefox. uninstall and then reinstall firefox. It will
> be solved (temporary solution till a fix is released)
> 
> # rpm --erase firefox --nodeps
> .
> # yum install firefox

Just wanted to mention that the fix mentioned breaks galeon and epiphany on my
system.  Not much of a fix, eh?
Comment 10 Alex Lancaster 2007-10-26 21:42:41 EDT
(In reply to comment #9)
> (In reply to comment #4)
> > gecko-libs is provided by Firefox. uninstall and then reinstall firefox. It will
> > be solved (temporary solution till a fix is released)
> > 
> > # rpm --erase firefox --nodeps
> > .
> > # yum install firefox
> 
> Just wanted to mention that the fix mentioned breaks galeon and epiphany on my
> system.  Not much of a fix, eh?

I would never suggest doing this.  You could uninstall galeon and that would
allow firefox to install, but then galeon will be uninstallable.

Also comment #8 is actually wrong.   galeon is not yet in updates-testing (nor
in updates).  epiphany *has* been rebuilt and is available in updates, and I
rebuilt galeon against the new firefox but we're still waiting on the powers
that be to actually push the galeon update.


Note You need to log in before you can comment on or make changes to this bug.