Bug 35152 - mount hangs with iso9660 on loop device
mount hangs with iso9660 on loop device
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-07 21:36 EDT by Rodary Jacques
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-09 22:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodary Jacques 2001-04-07 21:36:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.4.2smp i686)


I can' mount an iso9660 file on loop with my new custom kernel 2.4.2. I
can't even kill the mount command (I tried all signals). When I try to
reboot, the shutdown process hangs on "unmounting file systems". It worked
fine -and still does- with kernel 2.2.17-14. Did I forget something in
kernel config?

Reproducible: Always
Steps to Reproduce:
1. mount -vt iso9660 -o loop[=/dev/loop0] iso /mnt
2.
3.
	

Actual Results:  /var/log/messages says "Device not ready. Make sure there
is a disk in the drive"
Comment 1 Olivier Baudron 2001-04-09 08:43:13 EDT
An upgrade to 2.4.3 fixed the problem with loop device on my PC.
Comment 2 Alexei Podtelezhnikov 2001-04-09 19:37:19 EDT
this is a very known problem with 2.4.2 kernels. It's probably fixed in 0.1.49 
release in rawhide. It's definately fixed in Linus' 2.4.3. Basically you missed 
the fix in your new custom kernel.
Comment 3 Rodary Jacques 2001-04-09 22:42:11 EDT
It's OK with 2.4.3. But does anyone know what's wrong in 2.4.2?
Comment 4 Bernhard Rosenkraenzer 2001-04-15 17:30:38 EDT
I can't reproduce this with 2.4.2-2, assuming it's fixed.

Note You need to log in before you can comment on or make changes to this bug.