Bug 351541 - Driver only works after rmmod/modprobe
Driver only works after rmmod/modprobe
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iwl4965-firmware (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-24 19:54 EDT by Neal Becker
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-27 10:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2007-10-24 19:54:00 EDT
Description of problem:

Don't know if problem is driver or firmware.  I have:
02:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN 
Network Connection (rev 61)

When first loaded


Oct 24 19:45:24 nbecker1 kernel: iwl4965: Intel(R) Wireless WiFi Link 4965AGN 
driver for Linux, 1.1.17kds
Oct 24 19:45:24 nbecker1 kernel: iwl4965: Copyright(c) 2003-2007 Intel 
Corporation

sudo /sbin/iwlist wlan0 scan
wlan0     Interface doesn't support scanning.

ls /sys/class/net
eth0  lo

But after rmmod/modprobe, it works.  There is also 1 kernel message that 
wasn't there the first time, it's the 3rd one below:
Oct 24 19:45:24 nbecker1 kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 
(level, low) -> IRQ 16
Oct 24 19:45:24 nbecker1 kernel: iwl4965: Detected Intel Wireless WiFi Link 
4965AGN
Oct 24 19:45:24 nbecker1 kernel: iwl4965: Tunable channels: 11 802.11bg, 13 
802.11a channels

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nicolas Chauvet (kwizart) 2007-10-24 20:10:36 EDT
How did you installed iwl4965-firmware ? Was it installed at boot time ?

Anyway that's not a firmware package problem... 
Reassigned to someone who may know better...

(maybe kernel or NetworkManager or else )
Comment 2 Neal Becker 2007-10-24 20:55:55 EDT
I installed the iwl4965-firmware rpm.

As for loading the firmware into the chip, I don't know how that is supposed 
to happen, or how to tell if it did happen.  Any hints?
Comment 3 Nicolas Chauvet (kwizart) 2007-10-25 08:43:16 EDT
If you have installed manually the iwl4965-firmware rpm, then that's normal to
reload the module... If you have installed the firmware, then rebooted, then you
need to reload iwl4965 again, that's meant there is a problem... 
Comment 4 Neal Becker 2007-10-25 08:59:20 EDT
(In reply to comment #3)
> If you have installed manually the iwl4965-firmware rpm, then that's normal 
to
> reload the module... If you have installed the firmware, then rebooted, then 
you
> need to reload iwl4965 again, that's meant there is a problem... 

What does "installed the firmware" mean?  I installed the rpm.
Comment 5 Nicolas Chauvet (kwizart) 2007-10-25 09:13:11 EDT
where does this rpm come from ?
Comment 6 Neal Becker 2007-10-25 09:17:41 EDT
(In reply to comment #5)
> where does this rpm come from ?

rpm -q iwl4965-firmware
iwl4965-firmware-4.44.1.18-2.noarch
Comment 7 Nicolas Chauvet (kwizart) 2007-10-25 11:09:59 EDT
well ? why did you installed it ?
Wasn't the iwl4965-firmware installed already ?
(Have you run Fedora from a livecd or installed on hard disk ?)
Comment 8 Neal Becker 2007-10-25 13:21:13 EDT
(In reply to comment #7)
> well ? why did you installed it ?
> Wasn't the iwl4965-firmware installed already ?
> (Have you run Fedora from a livecd or installed on hard disk ?)

I installed F8T3 from disk.  Anaconda installed iwl4965-firmware.  I have 
since applied all updates from devel.
Comment 9 Nicolas Chauvet (kwizart) 2007-10-25 13:31:50 EDT
Ok, so you have it installed to your drive, but does the problem still appear if
you have rebooted ? (and the same tweaks have to be done each time you reboot ?)

Does it affect the chip detection if you have your "radio kill switch" on/off
before reboot ?

your message on the fedora-devel ml say also:
> Oct 24 09:44:06 nbecker1 NetworkManager: <WARN>
> killswitch_getpower_reply(): Error getting killswitch power:
> hal-ipw-killswitch-linux returned 255.

Why don't you have mentionned this on this bug ???

Which is your laptol model ?

Please be accurate in your answears !

Comment 10 Nicolas Chauvet (kwizart) 2007-10-26 12:18:55 EDT
Neal. The problem might be related with "radio kill switch" which vary between
many kind of implementation... AFAIK i don't knwo how to determine which is
your. So a good information to start would be to tell which is you laptop model ?...

Comment 11 Neal Becker 2007-10-26 12:42:36 EDT
(In reply to comment #10)
> Neal. The problem might be related with "radio kill switch" which vary 
between
> many kind of implementation... AFAIK i don't knwo how to determine which is
> your. So a good information to start would be to tell which is you laptop 
model ?...
> 
> 

Sure.  HP dv9000t (brand new)
Comment 12 Nicolas Chauvet (kwizart) 2007-10-26 20:42:32 EDT
from your ml list message:
I suppose the bug can be closed.
Can you confirm this ?
Comment 13 Neal Becker 2007-10-26 21:00:38 EDT
(In reply to comment #12)
> from your ml list message:
> I suppose the bug can be closed.
> Can you confirm this ?

Seems OK, thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.