Bug 352101 - Miro should depend on gecko-libs not firefox
Miro should depend on gecko-libs not firefox
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 07:51 EDT by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.9.8.1-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 15:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-10-25 07:51:10 EDT
Description of problem:

I believe the dependency of the package on specific version of firefox is
incorrect. The package should depend on gecko-lib instead.

Not having the correct dependency makes it harder to track packages that should
be rebuilt when firefox/gecko-libs is rebuilt and causes dependency and possibly
security problems.

Version-Release number of selected component (if applicable):

Miro-0:0.9.8.1-6.fc8.i386
Comment 1 Alex Lancaster 2007-10-25 08:15:19 EDT
I just rebuilt Miro for firefox 2.0.0.8 on f8 and f7, after that's pushed for f7
and f8-final, I'll look at fixing the spec file to not be specific for a
particular version (assuming that is indeed the case).

Thorsten Scherf just made me a co-maintainer.
Comment 2 Christopher Aillon 2007-10-25 12:58:25 EDT
To clarify, do not depend on firefox period.  Change the dependency to gecko-libs.

BAD:
Requires: firefox = 2.0.0.8

GOOD:
Requires: gecko-libs = 1.8.1.8


This will make the transition to xulrunner easier.  (Same for firefox-devel,
please change it to gecko-devel)
Comment 3 Alex Lancaster 2007-10-25 17:27:57 EDT
OK, but that still means a rebuild of Miro would be required when a new firefox
comes out, because (for the moment) firefox provides gecko-libs and the version
of gecko-libs is bumped on each new firefox release at the moment.

I thought that Lubomir was suggesting that the Requires doesn't need to be
versioned.
Comment 4 Lubomir Kundrak 2007-10-25 17:37:36 EDT
Alex: I didn't mean that. Obviously, as many people thought that, I chose bad
wording. I apologize for that.
Comment 5 Alex Lancaster 2007-10-25 17:50:49 EDT
(In reply to comment #4)
> Alex: I didn't mean that. Obviously, as many people thought that, I chose bad
> wording. I apologize for that.

OK, so the Requires will still need to be versioned, but versioned for
gecko-libs right?  Anyway I've updated the bug summary to make it clear what the
change will need to be, and I'll get working on this once the new updates have
hit the repositories and things have settled down a bit.
Comment 6 Christopher Aillon 2007-10-26 06:46:19 EDT
Correct.  Still versioned requires, just against gecko-libs.
Comment 7 Jack Deslippe 2007-10-30 02:27:40 EDT
Is there an rpm of miro I can install on my f7 system that will work?  The
current one in the repo nees firefox 2.0.0.5 and I have 2.0.0.8 now (I
uninstalled miro to do the firefox update because I thought it was important). 
If I install the miro in the repo with no-deps it does not run because it is
looking for a mozilla library in the old directory.  
Comment 8 Lubomir Kundrak 2007-10-30 11:56:47 EDT
Jack: It was pushed yesterday and should be on mirrors. Check again.
Comment 9 Jack Deslippe 2007-10-30 14:16:48 EDT
Ah, ok.  I got it installed, thanks.  Unfortunately I realized it is v 0.9.8 and
not the latest 0.9.9 (from getmiro.org) which fixed the startup bug for me.  Any
chance 0.9.9 will be built soon?
Comment 10 Lubomir Kundrak 2007-10-30 15:10:26 EDT
Jack: It seems like 0.9.9 is not built yet, even for Fedora 9 [1]. However,
though I can not answer your question, I suggest you asked maintainer to either
backport the patch for the fix or bump version by opening a bugzilla ticket for
the bug in question.

[1] http://koji.fedoraproject.org/koji/packageinfo?packageID=4854

Do not use this ticket, as the issue it describes has been properly fixed.
Comment 11 Alex Lancaster 2007-10-30 17:34:48 EDT
(In reply to comment #9)
> Ah, ok.  I got it installed, thanks.  Unfortunately I realized it is v 0.9.8 and
> not the latest 0.9.9 (from getmiro.org) which fixed the startup bug for me.  Any
> chance 0.9.9 will be built soon?

As a new co-maintainer of Miro I am in the process of building the new 0.9.9
version of Miro (there are some issues that need to be resolved with the package
first).
Comment 12 Jack Deslippe 2007-10-30 19:43:13 EDT
Hi, thanks for your answers even though I posted in the wrong place.  I look
forward to 0.9.9.  :)

Note You need to log in before you can comment on or make changes to this bug.