Bug 352211 - rhel server5 unable to connect Samba share using FQDN
rhel server5 unable to connect Samba share using FQDN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Samba Maint Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 08:51 EDT by Andre ten Bohmer
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: samba-3.0.25b-0.el5.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 15:24:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre ten Bohmer 2007-10-25 08:51:13 EDT
I've several RH ELS 5 installations running with Samba authenticating
via ADS. Al running well until mid june, since then it's only possible
to connect to these servers shares on a windows client via the servers
IP address. Connecting via FQDN or hostname show a logon window without
ever accepting a connection.
Seems window clients authenticate via NTLMSSP when using the servers IP
address and Kerberos otherwise. So I guess something got broken with
RedHat updates in june, but I've been unable to track down what caused
this misbehaviour. The problem was there before recent RedHat Kerberos
updates btw.
Any ideas?

Samba log
Using FQDN from client 83 :
]# cat 83.log
[2007/10/25 14:40:46, 0] lib/util_sock.c:write_data(562)
  write_data: write failure in writing to client 137.224.x.x. Error Connection
reset by peer
[2007/10/25 14:40:46, 0] lib/util_sock.c:send_smb(769)
  Error writing 4 bytes to client. -1. (Connection reset by peer)

]# cat 137.224.x.x.log 
[2007/10/25 14:40:46, 1] smbd/sesssetup.c:reply_spnego_kerberos(310)
  Username WUR\83$ is invalid on this system
[2007/10/25 14:40:49, 1] smbd/sesssetup.c:reply_spnego_kerberos(310)
  Username WUR\83$ is invalid on this system
[2007/10/25 14:40:49, 1] smbd/sesssetup.c:reply_spnego_kerberos(334)
  make_server_info_info3 failed: NT_STATUS_NO_SUCH_USER!
Comment 1 Andre ten Bohmer 2007-10-25 08:56:44 EDT
Sorry:
The problem was there before recent RedHat Kerberos
updates btw.
Should be:
There was no problem before recent RedHat Kerberos
updates btw (june 2007).
Comment 2 Simo Sorce 2007-11-13 11:08:56 EST
what does wbinfo -t and net rpc testjoin return ?
Comment 3 Andre ten Bohmer 2007-11-15 04:53:06 EST
Problem seems to be solved in 5.1
Comment 4 Simo Sorce 2007-11-16 15:24:16 EST
Thanks closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.