Bug 352221 - iwl4965 device not detected on first load of iwl4965 module
iwl4965 device not detected on first load of iwl4965 module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 09:15 EDT by Jes Sorensen
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 09:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vv (15.62 KB, text/plain)
2007-10-25 09:15 EDT, Jes Sorensen
no flags Details
Patch fixing the problem (707 bytes, text/x-patch)
2007-10-26 11:23 EDT, Jes Sorensen
no flags Details

  None (edit)
Description Jes Sorensen 2007-10-25 09:15:51 EDT
Description of problem:

iwl4965 driver in latest FC8T3 kernel does not detect the interface
on first load of module, preventing wireless network access. If I
unload the module and reload it, my network interface is detected.

Version-Release number of selected component (if applicable):
2.6.23-1-31.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Boot system
2. As root - rmmod iwl4965
3. As root - modprobe iwl4965

Actual results:


Expected results:


Additional info:

This problem is on an brand new Toshiba Portege R500 laptop, dual core x86_64.
Comment 1 Jes Sorensen 2007-10-25 09:15:51 EDT
Created attachment 237351 [details]
output of lspci -vv
Comment 2 Jes Sorensen 2007-10-26 11:23:02 EDT
Created attachment 239211 [details]
Patch fixing the problem

Ok, here's a patch to fix the problem.

The problem was that the driver didn't clear all interrupts in the 
chip before enabling interrupts and on my laptop it ended up taking
the interrupt long before the driver was ready to handle it.

Cheers,
Jes
Comment 3 John W. Linville 2007-10-26 17:11:32 EDT
Would you mind giving these kernels a quick test?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=22511
Comment 4 Jes Sorensen 2007-10-29 11:06:31 EDT
Your kernel seems to do the trick here - thanks!

Jes

Note You need to log in before you can comment on or make changes to this bug.