Bug 35238 - Turkish console fonts do not exist in the distributions
Summary: Turkish console fonts do not exist in the distributions
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-08 19:01 UTC by Burak Demircan
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-27 20:35:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
most popular 3 turkish console font which should come with default distributions (5.94 KB, application/octet-stream)
2001-04-08 19:05 UTC, Burak Demircan
no flags Details

Description Burak Demircan 2001-04-08 19:01:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)


Although user can select trq (which is 99.9 % used by Turkish users),
the Turkish console fonts do not exist in distributions. I have the 
correct fonts which is added as third part by all users but we want as
default.

Reproducible: Always
Steps to Reproduce:
1.run kbdconfig
2.select trq
3.although the keymap is defined due to turkish console fonts do not
exist, users can not see some the characters they press.
	

Actual Results:  although the keymap is defined, due to the fact hat 
turkish console fonts do not exist, users can not see some the characters 
they press.


Expected Results:  the correct characters should be seen instead of 
strange characters

My e-mail is: bdemircan@yahoo.com and I can send most popular 3
turkish console fonts to you.

Comment 1 Burak Demircan 2001-04-08 19:05:50 UTC
Created attachment 14944 [details]
most popular 3 turkish console font which should come with default distributions

Comment 2 Bill Nottingham 2001-04-08 20:26:38 UTC
console fonts are included in the console-tools package. Assigning there.

Comment 3 Bernhard Rosenkraenzer 2001-05-17 19:36:46 UTC
Does kbd-1.05-3 (from Rawhide) work for you? It includes lat5-{12,14,16} 
fonts, which IMO should be sufficient, but unfortunately I can't read Turkish.


Comment 4 Burak Demircan 2001-05-17 19:49:54 UTC
Yes you are right. Those fonts are now in these package with version 7.1
My bug was submitted when readhat 7.1 was not available.

The problem is going on in a different way in readhat 7.1.
Those fonts are perfect for turkish language but when a
user selects trq with kbdconfig it just selects the correct
keymap. The default font also should be selected as latin-5 (14)
I solved my problem by changing /etc/sysconfig/i18n file as turkish
settings.


Comment 5 Bernhard Rosenkraenzer 2001-05-17 20:36:36 UTC
Assigning to kbdconfig for that part of the problem.


Comment 6 Bill Nottingham 2001-07-10 19:21:00 UTC
kbdconfig doesn't actually handle console font assignment. Assigning to anaconda.

Comment 7 Matt Wilson 2001-08-15 20:39:00 UTC
the next release is going to use lat5-sun16 which has full line drawing chars
for the console.



Note You need to log in before you can comment on or make changes to this bug.