This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 352531 - leftover files in /tmp
leftover files in /tmp
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 11:43 EDT by John Reiser
Modified: 2013-01-09 20:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 15:42:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2007-10-25 11:43:28 EDT
Description of problem: After running pungi to create install media, then there
are leftover files and directories in /tmp.


Version-Release number of selected component (if applicable):
pungi-1.1.6-1.fc8

How reproducible: always


Steps to Reproduce:
1. run the EXAMPLE from the pungi man page
2.
3.
  
Actual results: Leftover files in /tmp:
instimage.mnt.<pid>
instimagemods.<pid>
keymaps-$ARCH.<pid>
makebootdisk.dir.<pid>
minstg2.img.<pid>
modinfo-$ARCH.<pid>
treedir.<pid>

Expected results: no leftover files or directories in /tmp

Additional info:
Comment 1 John Reiser 2007-10-25 12:02:50 EDT
Also /tmp/virtual-$USR.<random>
Comment 2 Jesse Keating 2007-10-25 12:04:38 EDT
This is due to there being a bug somewhere in buildinstall wrt setting a TMPDIR
or workdir for anacona-runtime to do its stuff in.  I think this actually got
fixed very recently and I need to do some validation of this and re-enable the
TMPDIR setting in pungi to force anaconda-runtime to use the work directory in
the destdir.  This isn't a change I'll be making before F8 goes out though, but
as an update to pungi later on.
Comment 3 Jesse Keating 2007-11-15 15:42:07 EST
Filed and tracked as https://hosted.fedoraproject.org/projects/pungi/ticket/58

Note You need to log in before you can comment on or make changes to this bug.