Bug 35273 - up2date/rhnd fails after upgrading to rpm-4.0-4 build
up2date/rhnd fails after upgrading to rpm-4.0-4 build
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-08 21:26 EDT by David Means
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-08 21:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Means 2001-04-08 21:26:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


up2date fails with this error after installing latest RPM build.

1$ up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/python1.5/site-packages/rpmmodule.so: undefined
symbol: rpmSetVerbosity

After upgrading to rpm-4.0-4, it appears that the following 
builds are not compatible:

rpm --query rpm python rpm-python up2date
rpm-4.0-4
python-1.5.2-27
rpm-python-4.0-4
up2date-2.1.7-1







Reproducible: Always
Steps to Reproduce:
1. Upgrade to RPM version 4.0-4
2. run up2date 
3.
	

Actual Results:  up2date fails to function.  rhnd fails to function
Comment 1 Preston Brown 2001-04-09 13:35:50 EDT
RPM rpm-4.0.2-7x is the latest errata release of RPM.  You need to make sure 
you are applying _official_ Red Hat errata.

http://support.redhat.com/errata

http://www.redhat.com/network

Note You need to log in before you can comment on or make changes to this bug.