Bug 35274 - Kernel 2.4.2-0.1.49 detects 80w IDE cable as 40w
Kernel 2.4.2-0.1.49 detects 80w IDE cable as 40w
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-08 21:40 EDT by Herbert Rutledge
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-08 21:40:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert Rutledge 2001-04-08 21:40:55 EDT
Kernel 2.4.2-0.1.49 detects 80w IDE cable as 40w with VIA VTC82C686A
chipset, thus setting UDMA 33 instead of UDMA 66.  Kernel compiled using
VIA chipset and Use DMA by Default options.

From /proc/ide/via using Kernel 2.4.2-0.1.28:

< Cable Type:                   80w                 80w
< Cycle Time:          30ns      60ns      30ns     180ns
< Transfer Rate:   66.0MB/s  33.0MB/s  66.0MB/s  11.0MB/s

From /proc/ide/via using Kernel 2.4.2-0.1.49:

> Cable Type:                   40w                 40w
> Cycle Time:          60ns      60ns      60ns     180ns
> Transfer Rate:   33.0MB/s  33.0MB/s  33.0MB/s  11.0MB/s
Comment 1 Arjan van de Ven 2001-04-09 09:07:44 EDT
I'm sorry to say this, but this is by design.
VIA is the only chipset that even offers the ability to autodetect the 80ribbon
cable, but we have disabled this in our kernel as we found that the chipset
misdetected this (and as a consequence, corrupted / crashed) in cirtain
circumstances.

You should be able to override this on the lilo commandline (or in a lilo
"append" line) by specifying "ideX=ata66", where X is 0 or 1 (0 is primary
cable, 1 is secondary cable). I have to warn you though. Some versions of the
VIA chipset have a bug where they corrupt data on disk or crash, even if you
do have the 80 ribbon cable.

If you do try the "ide0=ata66" option, and it does not work, please reopen this
bug.
Comment 2 vvs 2001-08-21 04:20:58 EDT
"VIA is the only chipset that even offers the ability to autodetect the 80ribbon
cable" ???

Somehow I doubt it. I have an Intel 815E chipset and it happily autodetects 40-
and 80-ribbon cables. This chipset was available at least from June 2000.

Note You need to log in before you can comment on or make changes to this bug.