Bug 352881 - iwl3945 does not work after resume
iwl3945 does not work after resume
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 13:49 EDT by Julian Sikorski
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.23.1-49.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 11:11:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-10-25 13:49:15 EDT
Description of problem:
Sometimes after resume from either S3 or S4, the network list in NM is empty and
stays that way. The only way to get network working again is to reload iwl3945.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-26.fc8.x86_64
NetworkManager-1:0.7.0-0.3.svn3014.fc8.x86_64

How reproducible:
Most of the times

Steps to Reproduce:
1. Get a PC with Intel Pro Wireless 3945
2. Hibernate/Suspend
3. Resume
  
Actual results:
iwl3945 is not back in usable state

Expected results:
Network is working
Comment 1 Julian Sikorski 2007-11-06 15:13:57 EST
Now that's peculiar:

[root@snowball ~]# lsmod | grep iwl
iwl3945               175657  0 
mac80211              148433  1 iwl3945
[root@snowball ~]# rmmod iwl3945
[root@snowball ~]# lsmod | grep iwl
iwl3945               175657  0 
mac80211              148433  1 iwl3945
[root@snowball ~]# 

It seems that rmmod gives the module some sort of wakeup kick, it starts working
without the need for modprobe.
Comment 2 Danny Baumann 2007-11-09 02:16:03 EST
I experience exactly the same.
Kernel
NetworkManager

iwl3945 will fail to reassociate without running rmmod first. From
/var/log/messages:
Nov  9 08:09:39 mobilrechner NetworkManager: <info>  Config: added 'group' value
'WEP40 WEP104 TKIP CCMP'
Nov  9 08:09:39 mobilrechner NetworkManager: <info>  Activation (wlan0) Stage 2
of 5 (Device Configure) complete.
Nov  9 08:09:39 mobilrechner NetworkManager: <info>  (wlan0) Supplicant
interface state change: 0 -> 2
Nov  9 08:10:04 mobilrechner NetworkManager: <info>  Activation
(wlan0/wireless): association took too long, asking for new key.
Nov  9 08:10:04 mobilrechner NetworkManager: <info>  (wlan0) Supplicant
interface state change: 2 -> 0
Comment 3 Danny Baumann 2007-11-09 02:17:18 EST
This was meant to read
Kernel: kernel-2.6.23.1-42.fc8
NetworkManager: NetworkManager-0.7.0-0.5.svn3030.fc8
Comment 4 Danny Baumann 2007-11-11 12:56:27 EST
kernel-2.6.23.1-49.fc8 seems to have fixed the issue for me. After resume,
NetworkManager reconnects to the AP after around 1 second. I tried 3 resumes so
far; I will give feedback if anything goes wrong again.
Comment 5 Julian Sikorski 2007-11-12 09:22:14 EST
Hmm, it really seems to be fixed with the mentioned kernel.

Note You need to log in before you can comment on or make changes to this bug.