Bug 353041 - confusing behavior on upgrades with multiple Obsoletes:
confusing behavior on upgrades with multiple Obsoletes:
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-25 15:17 EDT by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 08:36:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-10-25 15:17:15 EDT
Description of problem:

[root@apone ~]# rpm -q --qf "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" esound
esound-0.2.36-3.x86_64
[root@apone ~]# yum upgrade
Repository 'foo' is missing name in configuration, using id
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package esound.x86_64 1:0.2.38-5.fc8 set to be updated
--> Processing Dependency: libesd.so.0()(64bit) for package: esound
---> Package pulseaudio-esound-compat.x86_64 0:0.9.7-0.16.svn20071017.fc8 set to
be updated
--> Running transaction check
---> Package esound-libs.x86_64 1:0.2.38-5.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 esound                  x86_64     1:0.2.38-5.fc8   development        74 k
     replacing  esound.x86_64 1:0.2.36-3

 pulseaudio-esound-compat  x86_64     0.9.7-0.16.svn20071017.fc8  development  
    8.1 k
     replacing  esound.x86_64 1:0.2.36-3

Installing for dependencies:
 esound-libs             x86_64     1:0.2.38-5.fc8   development        31 k

Transaction Summary
=============================================================================
Install      3 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 113 k
Is this ok [y/N]: y
Downloading Packages:
(1/3): esound-libs-0.2.38 100% |=========================|  31 kB    00:00     
(2/3): pulseaudio-esound- 100% |=========================| 8.1 kB    00:00     
(3/3): esound-0.2.38-5.fc 100% |=========================|  74 kB    00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: esound-libs                  ######################### [1/4] 
  Installing: esound                       ######################### [2/4] 
  Installing: pulseaudio-esound-compat     ######################### [3/4] 
  Cleanup   : esound                       ######################### [4/4] 

Installed: esound.x86_64 1:0.2.38-5.fc8 pulseaudio-esound-compat.x86_64
0:0.9.7-0.16.svn20071017.fc8
Dependency Installed: esound-libs.x86_64 1:0.2.38-5.fc8
Replaced: esound.x86_64 1:0.2.36-3
Complete!
[root@apone ~]# rpm -q --obsoletes esound
esound <= 1:0.2.36-4
[root@apone ~]# rpm -q --obsoletes pulseaudio-esound-compat
esound 

Version-Release number of selected component (if applicable):

yum-3.2.7-1.fc8

How reproducible:

Every time

Steps to Reproduce:
1. Install FC6 esound package.
2. Point upgrade at F8/rawhide repos
3. Upgrade
Comment 1 Seth Vidal 2008-03-12 11:11:32 EDT
I don't know how I missed this bug when it was originally filed What's confusing
here?
Comment 2 Bill Nottingham 2008-03-12 11:22:53 EDT
Trying to remember - I think the fact that it pulled in *two* packages for
Obsoletes.
Comment 3 Bug Zapper 2008-05-13 23:44:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Florian Festi 2008-05-30 08:36:22 EDT
What is strange here is the pulseaudio-esound-compat package. Don't do
unversioned obsoletes! NOTABUG

Note You need to log in before you can comment on or make changes to this bug.