Bug 35374 - vim-enhanced-5.7-8 displays a warning about 'ospeed' when starting.
vim-enhanced-5.7-8 displays a warning about 'ospeed' when starting.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-09 14:33 EDT by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 17:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2001-04-09 14:33:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14smp i686)


After running up2date this morning, vim started displaying the following
warning on startup:

vim: Symbol `ospeed' has different size in shared object, consider
re-linking

The program seems to run properly afterwards.

Reproducible: Always
Steps to Reproduce:
1. Upgrade to vim-enhanced-5.7-8
2. Execute 'vim --help'
	

Actual Results:  $ vim --help
vim: Symbol `ospeed' has different size in shared object, consider
re-linking
VIM - Vi IMproved 5.7 (2000 Jun 24, compiled Jan 29 2001 16:31:55)
usage: vim [options] [file ..]       edit specified file(s)
   or: vim [options] -               read text from stdin
   or: vim [options] -t tag          edit file where tag is defined
   or: vim [options] -q [errorfile]  edit file with first error

Options:
   --                   End of options
   -v                   Vi mode (like "vi")
   -e                   Ex mode (like "ex")
   -s                   Silent (batch) mode (only for "ex")
   -R                   Readonly mode (like "view")
   -Z                   Restricted mode (like "rvim")
   -m                   Modifications (writing files) not allowed
   -b                   Binary mode
   -l                   Lisp mode
   -C                   Compatible with Vi: 'compatible'
   -N                   Not fully Vi compatible: 'nocompatible'
   -V[N]                Verbose level
   -n                   No swap file, use memory only
   -r                   List swap files and exit
   -r (with file name)  Recover crashed session
   -L                   Same as -r
   -H                   start in Hebrew mode
   -F                   start in Farsi mode
   -T <terminal>        Set terminal type to <terminal>
   -o[N]                Open N windows (default: one for each file)
   +                    Start at end of file
   +<lnum>              Start at line <lnum>
   -c <command>         Execute <command> first
   -s <scriptin>        Read commands from script file <scriptin>
   -w <scriptout>       Append commands to script file <scriptout>
   -W <scriptout>       Write commands to script file <scriptout>
   -u <vimrc>           Use <vimrc> instead of any .vimrc
   -x                   Edit encrypted files
   -i <viminfo>         Use <viminfo> instead of .viminfo
   -h                   print Help (this message) and exit
   --version            print version information and exit


Expected Results:  $ vim --help
VIM - Vi IMproved 5.7 (2000 Jun 24, compiled Jan 29 2001 16:31:55)
usage: vim [options] [file ..]       edit specified file(s)
   or: vim [options] -               read text from stdin
   or: vim [options] -t tag          edit file where tag is defined
   or: vim [options] -q [errorfile]  edit file with first error

Options:
   --                   End of options
   -v                   Vi mode (like "vi")
   -e                   Ex mode (like "ex")
   -s         Silent (batch) mode (only for "ex")
   -R                   Readonly mode (like "view")
   -Z                   Restricted mode (like "rvim")
   -m                   Modifications (writing files) not allowed
   -b                   Binary mode
   -l                   Lisp mode
   -C                   Compatible with Vi: 'compatible'
   -N                   Not fully Vi compatible: 'nocompatible'
   -V[N]                Verbose level
   -n                   No swap file, use memory only
   -r                   List swap files and exit
   -r (with file name)  Recover crashed session
   -L                   Same as -r
   -H                   start in Hebrew mode
   -F                   start in Farsi mode
   -T <terminal>        Set terminal type to <terminal>
   -o[N]                Open N windows (default: one for each file)
   +                    Start at end of file
   +<lnum>              Start at line <lnum>
   -c <command>         Execute <command> first
   -s <scriptin>        Read commands from script file <scriptin>
   -w <scriptout>       Append commands to script file <scriptout>
   -W <scriptout>       Write commands to script file <scriptout>
   -u <vimrc>           Use <vimrc> instead of any .vimrc
   -x                   Edit encrypted files
   -i <viminfo>         Use <viminfo> instead of .viminfo
   -h                   print Help (this message) and exit
   --version            print version information and exit
Comment 1 Red Hat Bugzilla 2001-04-14 12:47:09 EDT
from /usr/share/doc/ncurses-5.2/ANNOUNCE:

     * change type of ospeed variable back to short to match its use in
       legacy applications. It was altered after ncurses 4.2 to speed_t
       to repair a type mismatch which was introduced after 1.9.4 in
       1995. The principal users of termcap continued to use short, which
       is not the same size.
       NOTE: A few applications will have to be recompiled (about 1% of
       the programs in a typical Linux distribution, 10% of the programs
       that use ncurses). These are easy to identify with nm or strings.

Comment 2 Red Hat Bugzilla 2004-08-24 17:27:51 EDT
long since fixed, forgot to close this one 

Note You need to log in before you can comment on or make changes to this bug.