This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 35376 - kernel crash with Soundblaster PCI 128 (es1371)
kernel crash with Soundblaster PCI 128 (es1371)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-09 14:48 EDT by Mathieu de Naurois
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 20:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mathieu de Naurois 2001-04-09 14:48:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.2.18 i686)


Hi, 
I got a Soundblaster PCI 128 (chip 5880).

When I load the driver (modprobe es1371) and start playing a sound (or
simply start esd), the system crashes. No "panic" message, just hangs up.
This is related to bug  18904

Here is the result of lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8371 [KX133] (rev 02)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8371 [KX133 AGP] 
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South]
(rev 22)
00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
(rev 30)
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev
10)
00:0f.0 Multimedia audio controller: Ensoniq CT5880 [AudioPCI] (rev 02)
00:11.0 SCSI storage controller: Advanced Micro Devices [AMD] 53c974
[PCscsi] (rev 10)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP
1X/2X (rev 5c)

Here is the log juste before the system crash:
Apr  9 20:31:28 gedeon kernel: es1371: version v0.27 time 16:10:24 Apr  1
2001
Apr  9 20:31:28 gedeon kernel: es1371: found chip, vendor id 0x1274 device
id 0x5880 revision 0x02
Apr  9 20:31:28 gedeon kernel: PCI: Found IRQ 10 for device 00:0f.0
Apr  9 20:31:28 gedeon kernel: PCI: The same IRQ used for device 00:0d.0
Apr  9 20:31:28 gedeon kernel: es1371: found es1371 rev 2 at io 0xe000 irq
10
Apr  9 20:31:28 gedeon kernel: es1371: features: joystick 0x0
Apr  9 20:31:28 gedeon kernel: ac97_codec: AC97 Audio codec, id:
0x8384:0x7609 (SigmaTel STAC9721/23)
Apr  9 20:31:28 gedeon insmod: Using
/lib/modules/2.4.2-0.1.49/kernel/drivers/sound/ac97_codec.o
Apr  9 20:31:28 gedeon insmod: Symbol version prefix ''
Apr  9 20:31:28 gedeon insmod: Using
/lib/modules/2.4.2-0.1.49/kernel/drivers/sound/soundcore.o
Apr  9 20:31:28 gedeon insmod: Using
/lib/modules/2.4.2-0.1.49/kernel/drivers/sound/es1371.o

My Soundblaster Card shares the interrupt 0x10 with my ethernet card. I
tried another Irq (and I tried to remover the ethernet card), but the same
things happens.

I used kernel 2.4.2-0.1.49



Reproducible: Always
Steps to Reproduce:
1./sbin/modprobe es1371
2.esd
3.
	

Actual Results:  System Crash

Expected Results:  Sound!
Comment 1 Tim Lundstrvm 2001-04-20 04:41:03 EDT
I have the same problem on my Dell Precision 220 dual processor machine with
Intel 810 sound (i810_audio module). The system freeze when I STOP playing.
Comment 2 Arjan van de Ven 2001-04-20 04:55:37 EDT
tim@ifm.liu.se: i810 sounds is a completely different driver, please open a new
bug about that.
Comment 3 Thomas Johansen 2001-04-23 18:50:18 EDT
I have exactly the same problem with my SoundBlaster PCI 64 card, system 
completely hangs when loading the es1370 driver. Might be related to the 
es1371 problem? This also was a problem with 2.4-test kernels, but worked
for 2.4-test14 (I think it was). Installing RedHat 7.1 from scratch 
(kernel-2.4.2-2) broke everything again.
Comment 4 Alan Cox 2001-05-19 15:55:58 EDT
There are known incompatibilities between es137x and a few VIA mainboards. Does
your sound work under other OS's on that board (or for that matter in Linux 2.2)
Comment 5 Thomas Johansen 2001-05-21 03:49:46 EDT
It works under windows and linux 2.2, yes. I think the problem was introduced
in the 2.4-test kernels, then fixed, and reappeared in 2.4.2 (didn't check
2.4.0 or 1). I'm sure it works with 2.4-test12.
Comment 6 Mathieu de Naurois 2001-05-21 03:58:14 EDT
My sound works perfectly under win$9x,
and it works with alsa driver 5.10 as well.

But it doesn't work with alsa 9.x, and neither with the stock drivers
from 2.2.x and 2.4.x kernels. 

I tried 2.4.4 kernel (compiled from source) and I noticed something strange:
Sometimes, I can get some sound after a quite long time of 'frozen machine': the
machine hangs
completely during 10 or 20 seconds, and I then get some sound, but with lots of
cracks and strange noises.

By the way, I can make the 2.4.x drivers works perfectly with the folowing
procedure:
1) load the alsa 5.10 driver,
2) play a sound, 
3) unload the alsa modules
4) load the native es1371 module

It seems like the alsa driver does some initialisation of the card,
initialisation that is missing in the kernel native driver.

Comment 7 Mathieu de Naurois 2001-09-25 04:51:21 EDT
This bug seems to have disappeared with the 2.4.7-2 kernel
from the roswell beta distribution.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.