Bug 35380 - Gateway Solo 9150 doesn't finish restart
Gateway Solo 9150 doesn't finish restart
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-09 16:20 EDT by Scott Schmit
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-05 20:16:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Scott Schmit 2001-04-09 16:20:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.40 i686; Nav)

When I /sbin/shutdown -r now (or equivalent), the laptop successfully shuts
down and begins to restart, but halts before the boot loader (lilo) can
start. The same situation existed in Red Hat 7.0, but the original kernel
from Wolverine doesn't have this problem. However, i've since upgraded to a
rawhide kernel (due to recommendations from those who'd know) and it no
longer works.

Reproducible: Always
Steps to Reproduce:
1. Reboot
2. Watch

Actual Results:  It runs through the bios screen and halts before the "LILO
boot:" would show.
Here's what the screen looks like at halt:

Pentium II 333 MHz
0000640K System RAM Passed
0097280K Extended RAM Passed
0256K Cache SRAM Passed
System BIOS shadowed
Video BIOS shadowed
Fixed Disk 0: TOSHIBA MK6412MAT
CD-ROM Drive: Identified
Mouse initialized


Expected Results:  Well, I don't recall what the bios under the original
wolverine kernel showed (I'm guessing it's the same as windows does), but
when windows reboots (successfully), the bios output is much shorter, as if
the bios has a separate routine it runs to reboot than standard. It looks

Fixed Disk 0: TOSHIBA MK6412MAT
CD-ROM Drive: Identified
Mouse initialized

LILO boot: <cursor>

Again, this failed reboot occurs under Guinness and Rawhide kernels, but
the "stock" Wolverine kernel successfully rebooted. I never tried Fisher on
the laptop, so I couldn't say how it worked. I hope this helps.
Comment 1 Arjan van de Ven 2001-04-18 11:24:33 EDT
Can you try to use the following options as commandline options on the
Comment 2 Scott Schmit 2001-04-18 23:54:34 EDT
Here's what I did to test this (in case it's invalid):
LILO boot: [text as shown below]
bash-2.04# shutdown -r now     # if I got this far
[wait for a lilo prompt]

"linux single" it reboots, but the LILO prompt never occurs
"linux reboot=c single" it reboots, but the LILO prompt never occurs
"linux reboot=h single" it reboots, but the LILO prompt never occurs
"linux reboot=b single" it reboots, but the LILO prompt never occurs
"linux reboot=w single" it never loads in the first place:
Loading linux...............
Uncompressing linux...

crc error

 -- System halted

another thing to note, which I didn't see before (but perhaps you knew) when the
LILO prompt never shows up, the "Press <F2> to enter setup..." prompt is still
there at the bottom of the screen.

Hope that helps!
Comment 3 Alan Cox 2001-05-19 15:57:22 EDT
Its crashing in the BIOS after the reset. That more than implies its a BIOS bug
where the BIOS fails to correctly reset all the hardware after Linux ran.
Comment 4 Arjan van de Ven 2001-05-19 15:59:41 EDT
Oh could you try "apm=realmode" as option ?
Comment 5 Scott Schmit 2001-06-03 09:11:00 EDT
with linux single apm=realmode, linux single apm=realmode reboot=c, linux single
apm=realmode reboot=b, linux single apm=realmode reboot=h, there is no
change--it reboots, does the full bios check and freezes.

With linux single apm=realmode reboot=w, it still didn't work, but it did use
the shorter bios check seen when windows correctly/successfully reboots
(Implying it's closer).

Hope that helps

Note You need to log in before you can comment on or make changes to this bug.