Bug 353851 - kernel panic after kernel update
kernel panic after kernel update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 255861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 06:12 EDT by Pavel N. Shtanko
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.23.1-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 00:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot after kernel panic (110.04 KB, image/jpeg)
2007-10-26 06:12 EDT, Pavel N. Shtanko
no flags Details
lspci output (14.67 KB, text/plain)
2007-10-26 06:44 EDT, Pavel N. Shtanko
no flags Details
dmesg output (21.35 KB, text/plain)
2007-10-26 06:45 EDT, Pavel N. Shtanko
no flags Details

  None (edit)
Description Pavel N. Shtanko 2007-10-26 06:12:34 EDT
Description of problem:

kernel panic after update kernel from kernel-2.6.21-1.3194 to 2.6.22

Version-Release number of selected component (if applicable):


How reproducible:
yum update kernel

Steps to Reproduce:
1.yum update kernel -y
2.reboot

  
Actual results:
kernel panic

Expected results:
working computer

Additional info:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 47
model name      : AMD Athlon(tm) 64 Processor 3000+
stepping        : 2
cpu MHz         : 1800.000
cache size      : 512 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow
up pni lahf_lm
bogomips        : 3607.41
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc
Comment 1 Pavel N. Shtanko 2007-10-26 06:12:34 EDT
Created attachment 238801 [details]
screenshot after kernel panic
Comment 2 Pavel N. Shtanko 2007-10-26 06:44:16 EDT
Created attachment 238841 [details]
lspci output

lspci -vvxxx
Comment 3 Pavel N. Shtanko 2007-10-26 06:45:24 EDT
Created attachment 238851 [details]
dmesg output
Comment 4 Pavel N. Shtanko 2007-10-26 06:51:12 EDT
*** Bug 255861 has been marked as a duplicate of this bug. ***
Comment 5 Chuck Ebbert 2007-11-01 14:21:35 EDT
There may be settings in the system BIOS screens that enable/disable USB legacy
keyboard emulation, please try changing the settings if they are there.
Comment 6 Pavel N. Shtanko 2007-11-06 01:30:38 EST
No. in my BIOS this setting not present.
Comment 7 Pavel N. Shtanko 2007-11-06 01:41:55 EST
(In reply to comment #5)
> There may be settings in the system BIOS screens that enable/disable USB legacy
> keyboard emulation, please try changing the settings if they are there.
> 

No. In my BIOS this setting not present.
Only "Legacy USB support" set in auto. 
Comment 8 Chuck Ebbert 2007-11-06 14:31:33 EST
If you can change "legacy usb support", try that.
Comment 9 Pavel N. Shtanko 2007-11-07 03:21:32 EST
I tried. No effect. kernel panic again
Comment 10 Pete Zaitcev 2007-11-07 13:57:01 EST
If a function faults at +0, it very obviously is some kind of an annotation
error or module loading error. Maybe an extraneous __init somewhere.
Comment 11 Chuck Ebbert 2007-11-07 18:41:26 EST
Something has gone very wrong. The code at that address is all zeros. This may
be caused by the sparsemem memory allocation bug that was recently fixed. Have
you tried 2.6.23.1-21?

Note You need to log in before you can comment on or make changes to this bug.