Bug 354081 - Volume button icon is not shown in banshee
Volume button icon is not shown in banshee
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Nigel Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 09:37 EDT by Ronald
Modified: 2008-06-01 00:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-01 00:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot, notice the invisibility of the volume slider (it's there, but just not visible) (8.92 KB, image/png)
2007-10-26 09:37 EDT, Ronald
no flags Details

  None (edit)
Description Ronald 2007-10-26 09:37:24 EDT
Description of problem:

Banshee does have a slider for the volume. However, If I install banshee under
XFCE without Gnome, the icon is not available which will cause this slider do be
invisible...

Version-Release number of selected component (if applicable):

Latest development version from rawhide:

banshee-0.13.1-1.fc8

How reproducible:

Install banshee in a non-gnome environment

Steps to Reproduce:
1. Install banshee
2. Start banshee
3. Search for volume slider
  
Actual results:

Volume icon not visible

Expected results:

Volume icon visible

Additional info:

I'm not sure if this is a bug since this media player is not intended for a
non-gnome environment. I think this is the case because of the
'OnlyShowIn=GNOME;' that is in it's desktop file. I think this is not good,
because if you install dbus-x11 with banshee under XFCE and have the volume icon
back then it works perfect :)
Comment 1 Ronald 2007-10-26 09:37:24 EDT
Created attachment 239151 [details]
Screenshot, notice the invisibility of the volume slider (it's there, but just not visible)
Comment 2 Christopher Aillon 2007-12-26 08:55:01 EST
So are you saying this bug goes away if dbus-x11 is installed?
Comment 3 Ronald 2007-12-28 09:43:58 EST
Well, if you install banshee under XFCE you get the following problems:

- Volume button is not visible (this was wrong, it was my theme that did it.
Using the default Fedora theme does give a visible Volume button so that is not
a problem) (So that was my fault)

- Banshee starts complaining about not able to launch dbus-launch (or something
like that). This is fixed by doing: yum -y install dbus-x11 . So I think that
dbus-x11 should be a dependency of the banshee package :)
Comment 4 Christopher Aillon 2007-12-28 11:25:08 EST
So are you trying to combine two separate issues into one bug report?  Is
everything (including the volume button icon) fixed by installing that package?
 Or are there two different issues (please use two different bugs next time if so).
Comment 5 Ronald 2007-12-28 14:47:50 EST
Yes, these are two different issues. I thought they were related. But adding
dbus-x11 fixes the error about dbus-launch. The volume button is not visible due
to the icon theme I used (which was not distributed with Fedora). So that wrong.
Comment 6 Bug Zapper 2008-05-13 23:44:55 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Nigel Jones 2008-05-31 08:39:47 EDT
We now have Banshee 0.99.1 in updates, 0.99.2 in updates-testing and 0.99.3
getting ready to take over, can you please check if this bug still exists?

Thanks
Comment 8 Ronald 2008-05-31 08:59:33 EDT
Do you want me to check this with a Fedora 9 pre-release medium? I'm currently
not using Fedora anymore, however I'm willing to check it through qemu if that
suits your needs =)
Comment 9 Nigel Jones 2008-06-01 00:21:38 EDT
(In reply to comment #8)
> Do you want me to check this with a Fedora 9 pre-release medium? I'm currently
> not using Fedora anymore, however I'm willing to check it through qemu if that
> suits your needs =)

No, it's fine, I seem to recall the volume button appearing when I had 0.98.3 in
a similar situation, so I'll just close it.

Thanks for your original bug report though.

Note You need to log in before you can comment on or make changes to this bug.