Bug 35433 - Kernel freezes on excessively using RAID1
Kernel freezes on excessively using RAID1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-10 03:55 EDT by Klaus Muth
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 04:29:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Muth 2001-04-10 03:55:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.14-5.0 i686)


The kernel freezes on repeatedly copying very big files (1GB)
from one raid-1 to another

Reproducible: Always
Steps to Reproduce:
1. Install Redhat with 1 RAID1 (anaconda fails with 2 RAIDs, seems to
be a known bug)
2. Create 2nd Raid1 by hand and mount on /exports
3. Wait for both RAID to be clean
4. Create huge file: dd if=/dev/zero of=/root/tt bs=1M count=1k
5. run this script:
	#!/bin/sh
	file=tt
	i=0
	while [ true ]; do
		cp /root/${file} /exports
		rm -f /root/${file}
		cp /exports/${file} /root/
		rm -f /exports/${file}
		i=$(( $i + 1 ))
		echo "`date` $i " >> /root/copy.log
	done
		

Actual Results:  The kernel freezes after removing /root/tt after one or
more
copy actions.
I tried it with 1/2 GB File, that took longer to freeze, but 
it did freeze.

Expected Results:  The script runs the whole night and stops only on Ctrl-C

Got a Dual processor PentiumIII with ADAPTEC AIC-7892, and
4x 17GB IBM DDYS-T18350N HD
did a full installation of RedHat 7.0, with 2 RAID1's of 2HD's each.
Comment 1 Klaus Muth 2001-04-10 04:29:07 EDT
The freeze seems not to occur, when the copied file is small enough to
fit in the file cache. Here the copy script did the copy now for over 50
times (forth and back) without problems.
Comment 2 Klaus Muth 2001-05-21 04:30:52 EDT
Problem resolved.
The reason was crappy hardware. After replacing the server, this problem
did not occur again.

Note You need to log in before you can comment on or make changes to this bug.