Bug 35440 - rhn_register crashed in a RH6.2
Summary: rhn_register crashed in a RH6.2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-10 10:56 UTC by Need Real Name
Modified: 2015-01-07 23:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 00:16:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:048 normal SHIPPED_LIVE New Update Agent with many fixes and enhanced functionality available 2001-04-12 04:00:00 UTC

Description Need Real Name 2001-04-10 10:56:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


It fails

Reproducible: Always
Steps to Reproduce:
1.start rhn_register
2.Do the steps until it fails

	

Actual Results:  Traceback (innermost last):
  File "/usr/share/rhn/register/tui.py", line 1080, in ?
    main()
  File "/usr/share/rhn/register/tui.py", line 1076, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 1033, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 629, in __init__
    hardware.read_network()
  File "/usr/share/rhn/register/hardware.py", line 182, in read_network
    netdict['ipaddr'] = gethostbyname(gethostname())
socket.error: host not found


Packages installed I think are interesting
newt-0.50.17-1
newt-devel-0.50.17-1
up2date-2.1.7-0.6.x
rhn_register-1.0-7
python-xmlrpc-1.2.1-0.6.x
rpm-python-4.0.2-6x
pythonlib-1.23-1
python-1.5.2-27.6.x
openssl-0.9.5a-2.6.x

Comment 1 Jay Turner 2001-04-10 13:07:51 UTC
Sounds like one of two things.  Either the process is not finding a working
network connection, or it is not able to perform the hostname lookup on your
machine.  Verify that you do indeed have a working network connection and that
you either have a nameserver which is responding, or you have your hostname in
/etc/hosts

Comment 2 Need Real Name 2001-04-10 17:18:45 UTC
Hi here you are more info
the computer that has the poblem has two NICs one for internet and other for 
the LAN

[root@firewall /root]# cat /etc/resolv.conf
search telecable.es
nameserver 212.89.0.2
nameserver 212.89.0.5

[root@firewall /root]# cat /etc/hosts
127.0.0.1               localhost.localdomain localhost
#192.168.23.200         firewall


Comment 3 Preston Brown 2001-04-10 19:55:49 UTC
catching this traceback now in CVS.

Comment 4 Preston Brown 2001-04-12 20:54:48 UTC
fixed in errata due out today.

Comment 5 Matt Biermann 2001-06-19 15:47:38 UTC
This same problem happens on my 6.2 SPARC machine with latest errata 
installed.  

[root@k2 biermanm]# rhn_register
bash: rhn_register: command not found
[root@k2 biermanm]# /usr/sbin/rhn_register
Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 422, in __init__
    self.emailContactButton.setValue("*")
AttributeError: setValue
[root@k2 biermanm]#
[root@k2 biermanm]# rpm -qa |grep up2
up2date-2.5.4-0.6.x
[root@k2 biermanm]# rpm -qa |grep rhn
rhn_register-1.3.2-0.6.x



Comment 6 William Mulvihill 2001-06-26 16:21:28 UTC
to biermanm:  I had the same problem.  Only thing that I could do to get 

around it was using the Xwindows version.  I had the good luck to have 

another Xwindows enabled machine around so I merely did a remote X 

session.  Regardless, I think it is a bug in the text mode since I too got the 

same traceback as you.

Comment 7 Holger Eilhard 2001-11-02 15:07:54 UTC
Hello,

I'm having the same problem. Is there any fix available?

Thanks
Holger Eilhard

Comment 8 Kuszmaul, Bradley 2001-11-05 00:22:24 UTC
I had this bug, but then I upgraded from
 newt-0.50.8-2
to
 newt-0.50.22-2
which made the problem go away.

Under 0.50.8-2, the password did not show up as *'s when I typed it, and the
password showed as *'s under 0.50.22-2.


Comment 9 Adrian Likins 2001-11-06 20:37:31 UTC
hmm, this bug has divereged into two seperate bugs. the first
should already be fixed in released clients.

The other will be fixed in a soon to be release new package for 6.2. (it is
fixed in the 7.2 package as well). ie, the "setButton" traceback.

Comment 10 Need Real Name 2001-11-28 20:47:21 UTC
I had the same problem as biermanm on my sparc running RedHat 6.2... Updating
newt to version 0.50.22-2 got around that problem, and I was able to get to the
fourth screen (Step 2: Register a User Account (All Optional))  However, now it
crashes after I hit 'next' with the following traceback:

Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 590, in __init__
    self.versionLabel2 = snack.Label(rhnreg.getVersion())
  File "/usr/share/rhn/register/rhnreg.py", line 121, in getVersion
    index = db.findbyprovides("redhat-release")[0]
IndexError: list index out of range


It can't determine the version of RedHat that's installed?

Comment 11 Need Real Name 2001-11-29 10:15:00 UTC
Same thing here. I installed the latest version of up2date that was 
supposed to fix this (2.5.4-0.6.x) on an i386 architecture machine and 
rhn_register still just doesn't work in the text mode. With the newt version 
that was installed by default the script crashes when I click next on the 
username/password screen, with newt 0.50.22-2 it crashes one screen 
further and with newt 0.50.34-1 the script crashes on launch.

Come to think of it, I've never seen the text version of rhn_register work on 
any server I've ever installed.

Additional odd thing is I already have an RHN account but the text version 
of rhn_register still always treats me like a new user (starts to ask me 
registration questions). Why?


Note You need to log in before you can comment on or make changes to this bug.