Bug 354491 - rpm-devel should depend on popt-devel
rpm-devel should depend on popt-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 13:25 EDT by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-27 05:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-10-26 13:25:56 EDT
Description of problem:

/usr/include/rpm/rpmlib.h:15:18: error: popt.h: No such file or directory

/usr/include/rpm/rpmlib.h reads:
  15 #include "popt.h"

Version-Release number of selected component (if applicable):

rpm-devel-4.4.2.2-3.fc8

Additional info:

perl-RPM2 doesn't build because of this.
Comment 1 Panu Matilainen 2007-10-27 05:54:08 EDT
Already fixed in rawhide for some time but not visible because of the freeze:
https://koji.fedoraproject.org/koji/buildinfo?buildID=22144

Note You need to log in before you can comment on or make changes to this bug.