Bug 354921 - system-network-config cannot handle multi-homed host in /etc/hosts
system-network-config cannot handle multi-homed host in /etc/hosts
Status: CLOSED DUPLICATE of bug 442458
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-network (Show other bugs)
4.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On: 198898
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 17:14 EDT by Jeff Morriss
Modified: 2008-08-18 10:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 10:32:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Morriss 2007-10-26 17:14:49 EDT
Description of problem:

In my world (telecom) all systems are multi-homed and /etc/hosts is used a lot.
 The problem is that s-c-n can't seem to handle multi-homed hosts with
/etc/hosts entries.  For example I want:

172.16.3.4 myhost myhost-corp
10.1.2.3   myhost myhost-cluster0
10.1.3.3   myhost myhost-cluster1

(which is the correct format for /etc/hosts for a multi-homed system)

My problems are:

1) I can't create it using the GUI
2) (worse) if I manually edit /etc/hosts and set it like this, opening s-c-n and
then Saving corrupts what I created, writing out only the last IP address I had
defined for each host (e.g., 10.1.3.3 in the above example).

This bug is almost certainly blocked by bug 198898.

Version-Release number of selected component (if applicable):

system-config-network-tui-1.3.22.0.EL.4.2-1

How reproducible:

Problem 1 (can't put multiple IPs per host via the GUI):
Steps to Reproduce:
1. run system-config-network
2. create 2 or more entries with the same host name but different IP addresses
3. Save
  
Actual results:

/etc/hosts contains only the last-defined IP address

Expected results:

/etc/hosts contains all the entries I created.


Problem 2 (GUI corrupts manually created /etc/hosts):
Steps to Reproduce:
1. vi /etc/hosts and associate 3 IPs with your host (like in the description above)
2. run system-config-network
3. Save
  
Actual results:

/etc/hosts contains only the last-defined IP address (all my other hard work is
gone)

Expected results:

/etc/hosts contains all the entries that were there before.

Additional info:
Comment 1 Fabio Olive Leite 2007-11-12 15:24:21 EST
Sorry, I'm not the owner for this package.
Comment 2 Phil Knirsch 2008-08-18 10:32:00 EDT

*** This bug has been marked as a duplicate of bug 442458 ***

Note You need to log in before you can comment on or make changes to this bug.