This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 354941 - cairo ps and pdf output broken - _cairo_ps_surface_emit_truetype_font_subsets problem???
cairo ps and pdf output broken - _cairo_ps_surface_emit_truetype_font_subsets...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 17:43 EDT by John Ellson
Modified: 2008-02-21 15:19 EST (History)
0 users

See Also:
Fixed In Version: cairo-1.4.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 15:19:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bad postscript output generated on fc8 (30.74 KB, text/plain)
2007-10-26 17:43 EDT, John Ellson
no flags Details
good postscript output generated on fc7 (66.92 KB, application/postscript)
2007-10-26 17:44 EDT, John Ellson
no flags Details
test graph (791 bytes, text/plain)
2007-10-26 17:45 EDT, John Ellson
no flags Details

  None (edit)
Description John Ellson 2007-10-26 17:43:10 EDT
Description of problem:
Using identical graphviz sources from cvs, building on fc7 and todays rawhide. 
fc7s version works, fc8's not.   Problem can be reproduced with versions of
graphviz in distros, but the problem still exists if the graphviz version is the
same, so the problem is more likely to be in cairo.

Version-Release number of selected component (if applicable):
cairo-1.4.10-2.fc8.x86_64             <<< bad???
graphviz-2.14.1-3.fc8.x86_64

cairo-1.4.10-1.fc7.x86_64
graphviz-2.12-8.fc7.x86_64

How reproducible:
200%.    Problem was reported to the graphviz developers by another user

Steps to Reproduce:
1. On fc8:   dot -Tps:cairo appl.dot >appl.fc8.ps
2. On fc7:   dot -Tps:cairo appl.dot >appl.fc7.ps
3.
  
Actual results:
appl.fc7.ps is ok, appl.fc8.ps is bad.

Diffing the ps output shows significant changes, starting with:
    @@ -20,359 +20,758 @@
    /xyS{xyshow}bind def
    %%EndProlog
    % _cairo_ps_surface_emit_font_subsets
   -% _cairo_ps_surface_emit_truetype_font_subset
   -11 dict begin
   -/FontType 42 def
   -/FontName /CairoFont-0-0 def
   -/PaintType 0 def
   -/FontMatrix [ 1 0 0 1 0 0 ] def
    ...

Expected results:
viewable postscript


Additional info:
Comment 1 John Ellson 2007-10-26 17:43:10 EDT
Created attachment 239621 [details]
bad postscript output generated on fc8
Comment 2 John Ellson 2007-10-26 17:44:14 EDT
Created attachment 239631 [details]
good postscript output generated on fc7
Comment 3 John Ellson 2007-10-26 17:45:40 EDT
Created attachment 239641 [details]
test graph
Comment 4 John Ellson 2007-10-26 17:49:39 EDT
Problem can be fixed on fc8 by downgrading to cairo-1.4.10-1.fc7.x86_64.rpm
from fc7 updates.
Comment 5 John Ellson 2008-02-21 15:19:20 EST
Not sure when this was fixed, but I can't reproduce this bug now using:
  graphviz-2.14.1-3.fc8
  cairo-1.4.14-1.fc8.

Note You need to log in before you can comment on or make changes to this bug.