Bug 35555 - control-panel crashes when Package Management button clicked
control-panel crashes when Package Management button clicked
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: control-panel (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-11 00:52 EDT by Donna Robinson
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 07:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donna Robinson 2001-04-11 00:52:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i586)


output from gdb (after Ctrl C 'cos it hangs):
Program received signal SIGINT, Interrupt.
0x4039edf4 in __poll (fds=0x8082780, nfds=2, timeout=-1) at
../sysdeps/unix/sysv/linux/poll.c:63
63      ../sysdeps/unix/sysv/linux/poll.c: No such file or directory.
        in ../sysdeps/unix/sysv/linux/poll.c

(gdb) where
#0  0x4039edf4 in __poll (fds=0x8082780, nfds=2, timeout=-1) at
../sysdeps/unix/sysv/linux/poll.c:63
#1  0x4019e3b1 in g_main_poll () at eval.c:41
#2  0x4019dd22 in g_main_iterate () at eval.c:41
#3  0x4019e0fc in g_main_run () at eval.c:41
#4  0x400b4983 in gtk_main () at eval.c:41
#5  0x08049a75 in main () at eval.c:41
#6  0x402e6d4c in __libc_start_main (main=0x80499c0 <main>, argc=1,
ubp_av=0xbffff77c, 
    init=0x8049414 <_init>, fini=0x804a70c <_fini>, rtld_fini=0x4000d730
<_dl_fini>, 
    stack_end=0xbffff774) at ../sysdeps/generic/libc-start.c:129
(gdb) 


Reproducible: Always
Steps to Reproduce:
1. log in as root
2. control-panel &
3. Click on button "Package Management"

	

Actual Results:  root:/mnt/cdrom/RedHat/RPMS# control-panel
/usr/bin/glint: line 23: 16451 Segmentation fault      ./glint.py

( curse and type Ctrl-C yet again)


Expected Results:  well, a nice gui to hold my hand while i try to figure
out why redhat didn't install the freetype.h files in usr/include after
running rpm -i freetype-2.0.1-4.i386.rpm would have been nice


i just upgraded to RedHat 7.1 Beta 2 days ago.
Comment 1 Phil Knirsch 2001-04-18 07:12:24 EDT
Errhh, maybe i'm using the wrong version, but even logging in as root doesn't
offer a 'Package Management' option in the control-panel.

Do you need some other tools (like gnorpm) installed for that to appear?

Otherwise i can't reproduce this problem and therefore not fix it... :)

Read ya, Phil
Comment 2 Ngo Than 2001-04-23 09:22:25 EDT
the errors outputs say that you have installed the old control-panel and glint
RPM package management tool from Redhat-5.x. Update the both packages from RHL
7.1 should fix this problem.

Note You need to log in before you can comment on or make changes to this bug.