Bug 356121 - Dump does not default to level 9 as per the man page.
Dump does not default to level 9 as per the man page.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dump (Show other bugs)
5.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks: 409971
  Show dependency treegraph
 
Reported: 2007-10-28 21:52 EDT by Norm Murray
Modified: 2013-04-30 19:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 06:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Set the default dump level to 9. (291 bytes, text/x-patch)
2007-10-29 00:15 EDT, Wade Mealing
no flags Details

  None (edit)
Description Wade Mealing 2007-10-28 21:52:11 EDT
Description of problem:

The default increment dump level is not "9" when omit the option "-level".  This
 is is different than the expected behavior in the man page.

Version-Release number of selected component (if applicable):

dump-0.4b41-2.fc6.src.rpm (yes, el5)

How reproducible:

Every time

 1. suppose the test device is 'dev', and this device is smaller enough to dump
to the root filesystem (dev: for example /dev/sdb)
  2. execute command "dump -u -f back 'dev'"
  3. execute command "dump -f back 'dev'"
  4. execute command "file back | grep -i "level 9"

  
Actual results:

Dump level is 0.

Expected results:

Dump level should be 9 if no -[0-9] level specified as per man dump(8).



Additional info:
Comment 1 Wade Mealing 2007-10-29 00:15:32 EDT
Created attachment 241081 [details]
Set the default dump level to 9.

This sets the default dump level to 9.	It seems that pretty much everything
that that is incompatible with setting to 9 overrides the dump level anyway.
but to this is to be in accordance to the man page.

This may change expected behavior ( as it attempts to default to nothing (see
the select case in the code)
Comment 3 Adam Tkac 2007-10-31 08:20:37 EDT
Modify manpage sounds better for me because this behavior (dump level 0 by
default) is more intuitive than level 9 by default
Comment 15 Adam Tkac 2009-03-09 09:21:26 EDT
fixed in dump-0.4b41-3.el5
Comment 20 errata-xmlrpc 2009-04-15 06:14:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0425.html

Note You need to log in before you can comment on or make changes to this bug.