Bug 356191 - SVG is missing support for em and ex (as oppose to pt, or px) sizes
Summary: SVG is missing support for em and ex (as oppose to pt, or px) sizes
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL: http://www.omnifarious.org/~hopper/ba...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-29 05:39 UTC by Eric Hopper
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 12:25:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 305859 None None None Never

Description Eric Hopper 2007-10-29 05:39:49 UTC
Description of problem:
SVG images that specify the size in terms of em or ex end up having a width or
height of 0.

Version-Release number of selected component (if applicable):
firefox-2.0.0.8-1.fc7

How reproducible:
Every time

Steps to Reproduce:
1.Visit the given URL
  
Actual results:
A blank image

Expected results:
You should see an image depicting a glider from the game of life that's about
the height of 8 lines of text or so and about the same size wide.

Notes:
Since Microsoft Visio makes extensive use of sizes measured in em or ex when
told to produce an SVG file it would be very good if Firefox handled them properly.

Comment 1 Christopher Aillon 2007-10-30 12:25:40 UTC
This is recently implemented in what will become Firefox 3, but not yet in
Firefox 2.  We'll get this fixed when we update to 3.x

https://bugzilla.mozilla.org/show_bug.cgi?id=305859


Note You need to log in before you can comment on or make changes to this bug.