Bug 35693 - rpm -ql RaidMan seg faults (core dumped)
Summary: rpm -ql RaidMan seg faults (core dumped)
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-11 20:51 UTC by Zing
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 20:58:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zing 2001-04-11 20:51:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


A listing of the ServeRaid-4.50-manager-24p3818.rpm package seg faults in 
RH 7.0.

$ rpm -ql RaidMan
Segmentation fault (core dumped)

However -qi succeeds and I don't see any other packages affected.  I have 
tried an rpm --rebuilddb with no luck.  Same symptoms.

Reproducible: Always
Steps to Reproduce:
rpm -ql RaidMan core dumps every time.  

I have tried installing the package on another RH7.0 machine but was 
unable to reproduce the problem. :(


# rpm --version
RPM version 4.0.2
# ll /var/lib/rpm/
total 9284
-rw-r--r--    1 root     root      2637824 Apr 11 15:53 Basenames
-rw-r--r--    1 root     root        12288 Apr 11 15:53 Conflictname
-rw-r--r--    1 root     root        12288 Apr 11 15:53 Group
-rw-r--r--    1 root     root        12288 Apr 11 15:53 Name
-rw-r--r--    1 root     root      7184384 Apr 11 15:53 Packages
-rw-r--r--    1 root     root        49152 Apr 11 15:53 Providename
-rw-r--r--    1 root     root        77824 Apr 11 15:53 Requirename
-rw-r--r--    1 root     root        12288 Apr 11 15:53 Triggername

#gdb ./rpmq -q --list -- RaidMan core
(gdb) bt
#0  0x400623ce in showQueryPackage () from /usr/lib/librpm.so.0
#1  0x40063107 in showMatches () from /usr/lib/librpm.so.0
#2  0x400639d1 in rpmQueryVerify () from /usr/lib/librpm.so.0
#3  0x40063a49 in rpmQuery () from /usr/lib/librpm.so.0
#4  0x804aae3 in poptResetContext ()
#5  0x40169b5c in __libc_start_main (main=0x804a0f0
<poptResetContext+3376>,
    argc=5, ubp_av=0xbffffb0c, init=0x8049038 <_init>, fini=0x804ad2c
<_fini>,
    rtld_fini=0x4000d634 <_dl_fini>, stack_end=0xbffffb04)
    at ../sysdeps/generic/libc-start.c:129

ServeRaid Manager can be found: 
http://www.pc.ibm.com/qtechinfo/MIGR-495PES.html?
lang=en_US&page=brand&brand=IBM+PC+Server%7CServeRAID&family=IBM+PC+Server%
7CServeRAID&doctype=Downloadable+files&subtype=Cat&up=

What can I do to help?

Comment 1 Jeff Johnson 2001-04-11 21:01:37 UTC
Can you send me a pointer to (or copy of) the package? Thanks

Comment 2 Zing 2001-04-11 21:08:55 UTC
Here you go:
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers/24p2818.rpm

Comment 3 Jeff Johnson 2001-04-18 20:58:29 UTC
I can't reproduce this problem. Can you try doing a
	rpm --rebuilddb
and then reinstall the package using --force to see
if that cures the problem? Thanks

Comment 4 Zing 2001-04-19 14:49:18 UTC
Ok.  That worked.

One thing I didn't notice from before was a stray rpmrebuilddb.xxxx/ dated a 
couple hours after I installed rh 7.0 on this machine.  I may have cntrl-c a 
rpm --rebuilddb at that point, but I can't remember.  Not sure that that would 
affect the rpm database anyway.

Thanks.

Comment 5 Jeff Johnson 2001-04-19 16:02:28 UTC
Yes, you can/should do
	cd /var/lib
	rm -rf rpmrebuild*
to remove temp directories that were left behind from segfaulting --rebuilddb's


Note You need to log in before you can comment on or make changes to this bug.