Bug 357211 - gnome-system-log crashes frequently (again)
gnome-system-log crashes frequently (again)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 15:35 EDT by Julian Sikorski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1:2.20.0.1-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 17:57:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-10-29 15:35:16 EDT
Description of problem:
Maybe a bit less frequently than in my previous bug report, but it still hinders
the usability seriously:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496389168 (LWP 14903)]
0x000000000040b1c5 in logview_menus_set_state () at logview.c:274
274             monitor_active = (log->display_name == NULL);
(gdb) 
(gdb) bt
#0  0x000000000040b1c5 in logview_menus_set_state () at logview.c:274
#1  0x000000000040b59a in logview_select_log (log=0x4) at logview.c:214
#2  0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#3  0x000000328ce1a831 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
#4  0x000000328ce1bc73 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#5  0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#6  0x0000003409ab7853 in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
#7  0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#8  0x000000328ce1a831 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
#9  0x000000328ce1bc73 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#10 0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#11 0x0000003409b57f5d in gtk_list_store_remove ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x0000003409ab5e95 in gtk_combo_box_remove_text ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#13 0x000000000040841e in logview_update_version_bar () at log_repaint.c:230
#14 0x000000000040b642 in logview_select_log (log=0x9f5040) at logview.c:219
#15 0x000000000040d165 in loglist_selection_changed (selection=0x6be700)
    at loglist.c:253
#16 0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#17 0x000000328ce1a831 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#18 0x000000328ce1bc73 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#19 0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#20 0x0000003409c68e62 in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
#21 0x0000003409c7039d in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
#22 0x0000003409b61f91 in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
#23 0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#24 0x000000328ce1ae47 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
#25 0x000000328ce1ba47 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#26 0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#27 0x0000003409c84c3e in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
#28 0x0000003409b59b4c in gtk_propagate_event ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#29 0x0000003409b5acb9 in gtk_main_do_event ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#30 0x000000340924b82c in gtk_main_quit () from /usr/lib64/libgdk-x11-2.0.so.0
#31 0x000000328b62eea3 in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#32 0x000000328b63219d in gtk_main_quit () from /lib64/libglib-2.0.so.0
#33 0x000000328b6324aa in g_main_loop_run () from /lib64/libglib-2.0.so.0
#34 0x0000003409b5b0c3 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#35 0x0000000000406cd7 in main (argc=1, argv=0x7fffa09be338) at main.c:193
---Type <return> to continue, or q <return> to quit---
#36 0x0000003286e1e074 in __libc_start_main () from /lib64/libc.so.6
#37 0x0000000000406a09 in _start ()
(gdb) bt full
#0  0x000000000040b1c5 in logview_menus_set_state () at logview.c:274
        log = (Log *) 0x4
        calendar_active = 0
        monitor_active = 0
        __PRETTY_FUNCTION__ = "logview_menus_set_state"
#1  0x000000000040b59a in logview_select_log (log=0x4) at logview.c:214
        __PRETTY_FUNCTION__ = "logview_select_log"
#2  0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#3  0x000000328ce1a831 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#4  0x000000328ce1bc73 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
No symbol table info available.
#5  0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#6  0x0000003409ab7853 in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#7  0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#8  0x000000328ce1a831 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#9  0x000000328ce1bc73 in g_signal_emit_valist ()
---Type <return> to continue, or q <return> to quit---
   from /lib64/libgobject-2.0.so.0
No symbol table info available.
#10 0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#11 0x0000003409b57f5d in gtk_list_store_remove ()
   from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#12 0x0000003409ab5e95 in gtk_combo_box_remove_text ()
   from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#13 0x000000000040841e in logview_update_version_bar () at log_repaint.c:230
        recent = (Log *) 0x9f5040
        log = (Log *) 0x9f5040
        i = -1
        label = <value optimized out>
#14 0x000000000040b642 in logview_select_log (log=0x9f5040) at logview.c:219
        __PRETTY_FUNCTION__ = "logview_select_log"
#15 0x000000000040d165 in loglist_selection_changed (selection=0x6be700)
    at loglist.c:253
        model = (GtkTreeModel *) 0x75d4b0
        iter = {stamp = 1722247942, user_data = 0x8f2230, user_data2 = 0x0, 
  user_data3 = 0x0}
        bold = <value optimized out>
---Type <return> to continue, or q <return> to quit---
        name = (gchar *) 0x88b4d30 "maillog"
        log = (Log *) 0x9f5040
        __PRETTY_FUNCTION__ = "loglist_selection_changed"
#16 0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#17 0x000000328ce1a831 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#18 0x000000328ce1bc73 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
No symbol table info available.
#19 0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#20 0x0000003409c68e62 in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#21 0x0000003409c7039d in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#22 0x0000003409b61f91 in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#23 0x000000328ce0b1a9 in g_closure_invoke () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#24 0x000000328ce1ae47 in gtk_main_quit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#25 0x000000328ce1ba47 in g_signal_emit_valist ()
---Type <return> to continue, or q <return> to quit---
   from /lib64/libgobject-2.0.so.0
No symbol table info available.
#26 0x000000328ce1be43 in g_signal_emit () from /lib64/libgobject-2.0.so.0
No symbol table info available.
#27 0x0000003409c84c3e in gtk_main_quit () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#28 0x0000003409b59b4c in gtk_propagate_event ()
   from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#29 0x0000003409b5acb9 in gtk_main_do_event ()
   from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#30 0x000000340924b82c in gtk_main_quit () from /usr/lib64/libgdk-x11-2.0.so.0
No symbol table info available.
#31 0x000000328b62eea3 in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
No symbol table info available.
#32 0x000000328b63219d in gtk_main_quit () from /lib64/libglib-2.0.so.0
No symbol table info available.
#33 0x000000328b6324aa in g_main_loop_run () from /lib64/libglib-2.0.so.0
No symbol table info available.
#34 0x0000003409b5b0c3 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
---Type <return> to continue, or q <return> to quit---
#35 0x0000000000406cd7 in main (argc=1, argv=0x7fffa09be338) at main.c:193
        gnome_client = (GnomeClient *) 0x667bd0
        context = <value optimized out>
#36 0x0000003286e1e074 in __libc_start_main () from /lib64/libc.so.6
No symbol table info available.
#37 0x0000000000406a09 in _start ()
No symbol table info available.
(gdb) 

Version-Release number of selected component (if applicable):
gnome-utils-1:2.20.0.1-2.fc8.x86_64

How reproducible:
always

Steps to Reproduce:
1. start the program
2. change from one log file to another
  
Actual results:
program crashes after a few changes

Expected results:
no crash
Comment 1 Julian Sikorski 2007-11-02 05:50:55 EDT
Hmm, sometimes gdb has troubles grabbing the segfault, it reports that program
exited with exit code 013.
Comment 2 Julian Sikorski 2007-11-02 05:55:05 EDT
OK, I think I've got it - attaching to the process allowed to get the backtrace.
Here goes one with more debuginfo packages installed:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496389168 (LWP 7658)]
0x000000000040b1c5 in logview_menus_set_state () at logview.c:274
274             monitor_active = (log->display_name == NULL);
(gdb) bt
#0  0x000000000040b1c5 in logview_menus_set_state () at logview.c:274
#1  0x000000000040b59a in logview_select_log (log=0x4) at logview.c:214
#2  0x000000328ce0b1a9 in IA__g_closure_invoke (closure=0x7859c0, 
    return_value=0x0, n_param_values=1, param_values=0x7fffad15e2d0, 
    invocation_hint=0x7fffad15e1a0) at gclosure.c:490
#3  0x000000328ce1a831 in signal_emit_unlocked_R (node=0x77aff0, detail=0, 
    instance=0x763540, emission_return=0x0, instance_and_params=0x7fffad15e2d0)
    at gsignal.c:2440
#4  0x000000328ce1bc73 in IA__g_signal_emit_valist (instance=0x763540, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffad15e550)
    at gsignal.c:2199
#5  0x000000328ce1be43 in IA__g_signal_emit (instance=0x67e000, signal_id=0, 
    detail=6802928) at gsignal.c:2243
#6  0x0000003409ab7853 in gtk_combo_box_model_row_deleted (model=0x6dee30, 
    path=0x8fc0d00, user_data=0x763540) at gtkcombobox.c:3119
#7  0x000000328ce0b1a9 in IA__g_closure_invoke (closure=0x785950, 
    return_value=0x0, n_param_values=2, param_values=0x7fffad15e8e0, 
    invocation_hint=0x7fffad15e7b0) at gclosure.c:490
#8  0x000000328ce1a831 in signal_emit_unlocked_R (node=0x768e70, detail=0, 
    instance=0x6dee30, emission_return=0x0, instance_and_params=0x7fffad15e8e0)
    at gsignal.c:2440
#9  0x000000328ce1bc73 in IA__g_signal_emit_valist (instance=0x6dee30, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffad15eb60)
    at gsignal.c:2199
#10 0x000000328ce1be43 in IA__g_signal_emit (instance=0x67e000, signal_id=0, 
    detail=6802928) at gsignal.c:2243
#11 0x0000003409b57f5d in IA__gtk_list_store_remove (list_store=0x6dee30, 
    iter=0x7fffad15ec80) at gtkliststore.c:969
#12 0x0000003409ab5e95 in IA__gtk_combo_box_remove_text (combo_box=0x763540, 
    position=0) at gtkcombobox.c:5089
#13 0x000000000040841e in logview_update_version_bar () at log_repaint.c:230
#14 0x000000000040b642 in logview_select_log (log=0xa0aa70) at logview.c:219
#15 0x000000000040d165 in loglist_selection_changed (selection=0x6bf300)
    at loglist.c:253
#16 0x000000328ce0b1a9 in IA__g_closure_invoke (closure=0x77eb70, 
    return_value=0x0, n_param_values=1, param_values=0x7fffad15f040, 
    invocation_hint=0x7fffad15ef10) at gclosure.c:490
#17 0x000000328ce1a831 in signal_emit_unlocked_R (node=0x76ba60, detail=0, 
    instance=0x6bf300, emission_return=0x0, instance_and_params=0x7fffad15f040)
    at gsignal.c:2440
#18 0x000000328ce1bc73 in IA__g_signal_emit_valist (instance=0x6bf300, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffad15f2c0)
    at gsignal.c:2199
#19 0x000000328ce1be43 in IA__g_signal_emit (instance=0x67e000, signal_id=0, 
    detail=6802928) at gsignal.c:2243
#20 0x0000003409c68e62 in gtk_tree_view_real_set_cursor (tree_view=0x76c0a0, 
    path=0x904fd20, clear_and_select=1, clamp_node=1) at gtktreeview.c:12542
#21 0x0000003409c7039d in gtk_tree_view_button_press (widget=0x76c0a0, 
    event=0x90e1ac0) at gtktreeview.c:2710
#22 0x0000003409b61f91 in _gtk_marshal_BOOLEAN__BOXED (closure=0x66db50, 
    return_value=0x7fffad15f6f0, n_param_values=<value optimized out>, 
    param_values=0x7fffad15f7e0, invocation_hint=<value optimized out>, 
    marshal_data=0x3409c6fa80) at gtkmarshalers.c:84
#23 0x000000328ce0b1a9 in IA__g_closure_invoke (closure=0x66db50, 
    return_value=0x7fffad15f6f0, n_param_values=2, 
    param_values=0x7fffad15f7e0, invocation_hint=0x7fffad15f6b0)
    at gclosure.c:490
#24 0x000000328ce1ae47 in signal_emit_unlocked_R (node=0x66dbc0, detail=0, 
    instance=0x76c0a0, emission_return=0x7fffad15fa00, 
    instance_and_params=0x7fffad15f7e0) at gsignal.c:2478
#25 0x000000328ce1ba47 in IA__g_signal_emit_valist (instance=0x76c0a0, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffad15fa60)
    at gsignal.c:2209
#26 0x000000328ce1be43 in IA__g_signal_emit (instance=0x67e000, signal_id=0, 
    detail=6802928) at gsignal.c:2243
#27 0x0000003409c84c3e in gtk_widget_event_internal (widget=0x76c0a0, 
    event=0x90e1ac0) at gtkwidget.c:4675
#28 0x0000003409b59b4c in IA__gtk_propagate_event (widget=0x76c0a0, 
    event=0x90e1ac0) at gtkmain.c:2319
#29 0x0000003409b5acb9 in IA__gtk_main_do_event (event=0x90e1ac0)
    at gtkmain.c:1539
#30 0x000000340924b82c in gdk_event_dispatch (source=<value optimized out>, 
    callback=<value optimized out>, user_data=<value optimized out>)
    at gdkevents-x11.c:2351
#31 0x000000328b62eea3 in IA__g_main_context_dispatch (context=0x6228f0)
    at gmain.c:2061
#32 0x000000328b63219d in g_main_context_iterate (context=0x6228f0, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2694
#33 0x000000328b6324aa in IA__g_main_loop_run (loop=0x63f4d0) at gmain.c:2898
#34 0x0000003409b5b0c3 in IA__gtk_main () at gtkmain.c:1146
#35 0x0000000000406cd7 in main (argc=1, argv=0x7fffad15fec8) at main.c:193
#36 0x0000003286e1e074 in __libc_start_main (main=0x406ac0 <main>, argc=1, 
    ubp_av=0x7fffad15fec8, init=<value optimized out>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffad15feb8) at libc-start.c:220
#37 0x0000000000406a09 in _start ()
(gdb)
Comment 3 Matthias Clasen 2007-11-05 20:53:04 EST
I can't reproduce this. Are you doing anything in particular when the crash
happens ?
Comment 4 Julian Sikorski 2007-11-06 11:59:08 EST
No, just changing from one log to another. Not even scrolling through the contents.
Comment 5 Michael Lavallee 2007-11-10 14:19:25 EST
I am getting this as well with Fedora 8.  If I launch the program, it comes up
showing the cron log.  I can scroll through it, change dates, and access the
drop down menus.  But the moment I try and view any of the other log files it
segfaults.  I'm not sure where gnome-system-log stores its configuration; I was
going to try and find it and wipe it clean to start fresh.
Comment 6 Lars G 2007-11-10 18:40:28 EST
same as #5 here on fedora 8 for me.
Comment 7 Matthias Clasen 2007-11-11 00:09:38 EST
Do you still see the crashes when you turn off accessibility support ?
I'm seeing segfaults in gailtreeview.c
Comment 8 Fedora Update System 2007-11-12 18:54:55 EST
gail-1.20.1-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gail'
Comment 9 Julian Sikorski 2007-11-13 09:15:26 EST
Gail from testing repo does not help here.
Comment 10 Fedora Update System 2007-11-20 12:55:18 EST
gnome-utils-2.20.0.1-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-utils'
Comment 11 Julian Sikorski 2007-11-21 08:25:12 EST
Yay, this seems to have fixed the problem. Thanks.
Comment 12 Fedora Update System 2007-11-26 13:39:31 EST
gail-1.20.1-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2007-11-26 13:52:25 EST
gnome-utils-2.20.0.1-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.