Bug 357221 - system-install-packages crash with basearchonly
system-install-packages crash with basearchonly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 376771 382741 386591 388081 390891 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 15:40 EDT by Warren Togami
Modified: 2007-12-29 09:51 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.3.28-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 09:51:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback of system-install-packages (119.52 KB, text/plain)
2007-10-29 15:40 EDT, Warren Togami
no flags Details
When I try to invoke pup directly from the gnome menu. (1.63 KB, text/plain)
2007-12-29 08:32 EST, Leslie Satenstein
no flags Details

  None (edit)
Description Warren Togami 2007-10-29 15:40:14 EDT
yum-3.2.7-1.fc8
yum-basearchonly-1.1.8-1.fc8
pirut-1.3.25-2.fc8

Reproduce Procedure
===================
1) Click on a .rpm package on a website.
2) Launch system-install-packages.
3) Crash.

Infinite recursion due to bad assumptions made by basearchonly.
Comment 1 Warren Togami 2007-10-29 15:40:14 EDT
Created attachment 242341 [details]
Traceback of system-install-packages
Comment 2 Jeremy Katz 2007-11-12 11:29:34 EST
*** Bug 376771 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2007-11-15 20:03:04 EST
*** Bug 382741 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2007-11-16 11:08:44 EST
*** Bug 386591 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2007-11-19 11:44:13 EST
*** Bug 388081 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2007-11-19 13:27:44 EST
Fixed in git
Comment 7 Jeremy Katz 2007-11-19 14:26:17 EST
*** Bug 390891 has been marked as a duplicate of this bug. ***
Comment 8 Leslie Satenstein 2007-12-29 08:32:15 EST
Created attachment 290524 [details]
When I try to invoke pup directly from the gnome menu.

yumex still works.  RPM is also impacted and produces a similar file.
Comment 9 Jeremy Katz 2007-12-29 09:51:52 EST
Leslie -- that traceback is a different bug (it's bug 421961)

Note You need to log in before you can comment on or make changes to this bug.