Bug 357231 - default attachment type should be "text/plain"
default attachment type should be "text/plain"
Status: CLOSED UPSTREAM
Product: Bugzilla
Classification: Community
Component: Attachments/Requests (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 15:43 EDT by John Reiser
Modified: 2013-06-23 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-30 18:05:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2007-10-29 15:43:29 EDT
Description of problem: When creating an attachment, then bugzilla assumes that
the mime type is "application/octet-stream".  Instead, the default type should
be "text/plain".  The reason for this is that "application/octet-stream" does
not display at all in the default viewer, and it is too easy to forget to choose
"text/plain" explicitly, and cumbersome to change the mime type.


Version-Release number of selected component (if applicable):
Bugzilla Version 2.18-rh 

How reproducible: always


Steps to Reproduce:
1. Create an attachment: Browse to select a file, enter description, enter
comment, forget to select type (leave it as "bugzilla should guess")
2.
3.
  
Actual results: Mime type is application/octet-stream.


Expected results:  Mime type should be text/plain.


Additional info:
Comment 1 John Reiser 2007-10-29 15:48:48 EDT
Or, bugzilla's guess should be text/plain if the first 1KB of the file is
"printable ASCII".

I've stumbled on this a few times in the past two weeks.  All my attachments are
either plain text, or gzip'ed plain text.  The difference is obvious to the
'file' command, and bugzilla should make the correct choice, too.
Comment 2 David Lawrence 2008-09-16 12:55:32 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 3 David Lawrence 2008-11-30 18:05:54 EST
This should be filed upstream as we are not using stock attachment code.

https://bugzilla.mozilla.org

Thanks
Dave

Note You need to log in before you can comment on or make changes to this bug.