Bug 357491 - [5.2] <Shift> + <Tab> is unusable keyboard shortcut for HVM guest domain
[5.2] <Shift> + <Tab> is unusable keyboard shortcut for HVM guest domain
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk-vnc (Show other bugs)
5.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Martin Jenner
:
: 353701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-29 20:12 EDT by Saori Fukuta
Modified: 2009-09-02 05:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Re-fix shift+tab handling (1.92 KB, patch)
2009-07-06 07:33 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Saori Fukuta 2007-10-29 20:12:16 EDT
Description of problem:
  To control the focus, I want to use keyboard shortcuts.
  But <Shift> + <Tab> is unusable for HVM guest domain on the viewer of 
  virt-manager, <Tab> is usable though.
  virt-viewer has the same result.
  
  This problem does not occur with PV domain.

Version-Release number of selected component (if applicable):
  from RPM (RHEL5.1 RC):
    kernel-xen (kernel-xen-2.6.18-52.el5)
    xen (xen-3.0.3-41.el5)
  from cvs:
    virt-manager (changeset 637)
    virt-viewr (changeset 16)

How reproducible:
  always

Steps to Reproduce:
  1. Create a HVM guest domain
  2. Open the guest domain by using virt-manager or virt-viewer
  
Actual results:
  I cannot move the focus by <Shift> + <Tab>

Expected results:
  I can move the focus by <Shift> + <Tab>

Additional info:
  If there is other unusable keyboard shortcut, I will report it here.
Comment 1 Saori Fukuta 2007-10-29 20:15:33 EDT
*** Bug 353701 has been marked as a duplicate of this bug. ***
Comment 2 RHEL Product and Program Management 2007-10-30 19:34:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Tatsuro Enokura 2007-11-02 03:03:46 EDT
I think that the cause of this problem is not virt-viewer or gtk-vnc,
occurred by another module.

Let me tell you why I thought.
I debugged how the value of "keyvalue" was set at gtk_vnc
(gdk_keymap_translate_keyboard_state() in key_event() at vncdisplay.c), 
and I compared the result of them:
   shortcut       Domain           keyvalue      
   ---------------------------------------------
   <Shift><TAB>   HVM (unusable)   ISO_Left_Tab  
   <Shift><TAB>   PV  (usable)     ISO_Left_Tab  
But the setting value is same between HVM and PV.

Do you have any idea ?

Comment 4 RHEL Product and Program Management 2008-03-11 15:38:20 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 5 Saori Fukuta 2008-08-04 22:45:37 EDT
This bug has already fixed upstream (changeset 183 of gtk-vnc):
http://gtk-vnc.codemonkey.ws/hg/outgoing.hg/rev/f7fc5cf7bef0
Comment 6 Cole Robinson 2009-01-21 16:45:59 EST
Re-assigning to gtk-vnc.
Comment 8 Daniel Berrange 2009-02-25 05:36:15 EST
Upstream repository has now moved. The link from comment #5 now refers to:

http://git.gnome.org/cgit/gtk-vnc/commit/?id=1e121b4084788399c4d71d60b513997661e3116e
Comment 10 Daniel Berrange 2009-04-01 11:06:34 EDT
Fix built into gtk-vnc-0.3.8-1.el5
Comment 12 Chris Ward 2009-07-03 13:58:52 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 13 Mark Xie 2009-07-05 12:55:29 EDT
This issue still occur on X86-64 platform, <Shift> + <Tab> do not work in the application of the guest. Both virt-manager and virt-viewer have this issue, and it can be repoduced on all KVM, xen FV, xen PV base guest.

Package version:
gtk-vnc-0.3.8-2.el5
virt-manager-0.6.1-5.el5
virt-viewer-0.0.2-3.el5

Steps:
1, Open a KVM, xen FV or Xen PV guest.
2, Connect to it by virt-manager or virt-viewer.
3, Open a application or system configure utility, try the <Shift><Tab>.

Actual Results:
<Shift><Tab> do not work.

Expect Results:
The focus move to previous place when <Shift> + <Tab> pressed.

Additional info:
<Shift><Tab> works when the physical machines connected by vncviewer.
Comment 14 Daniel Berrange 2009-07-06 07:25:40 EDT
There was a regression in the fix upstream. Fixed it again with

http://git.gnome.org/cgit/gtk-vnc/commit/?id=b0a5d4d92884c4380bfbd23de6520ddbf41d91ca
Comment 15 Daniel Berrange 2009-07-06 07:33:34 EDT
Created attachment 350591 [details]
Re-fix shift+tab handling
Comment 18 Daniel Berrange 2009-07-08 09:00:13 EDT
Built in gtk-vnc-0.3.8-3.el5
Comment 22 errata-xmlrpc 2009-09-02 05:48:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1301.html

Note You need to log in before you can comment on or make changes to this bug.