Bug 35754 - Dual-boot machine lilo.conf messed up with QA0404 up2date.
Dual-boot machine lilo.conf messed up with QA0404 up2date.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-11 20:51 EDT by Lamar Owen
Modified: 2015-01-07 18:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-12 17:03:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lamar Owen 2001-04-11 20:51:40 EDT
Did an up2date upgrade to Seawolf from QA0404.

Machine is dual boot with default boot target as the dos partition.

Up2date modification of lilo.conf resulted in a new boot target (linux.bak) that is the old kernel, which boots ok. The new kernel is given the boot 
target of 'linux' -- which won't boot because no 'root=' entry is provided.  BUT the linux boot-target is marked as the default, instead of the dos 
target used before.  My _new_ lilo.conf as given to me by the up2date system is:
---------------------------------------------
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=linux

image=/boot/vmlinuz-2.4.2-0.1.49
	label=linux.bak
	read-only
	root=/dev/hda3

other=/dev/hda1
	label=dos

image=/boot/vmlinuz-2.4.2-2
	label=linux
	read-only

The old one was:
------------------------
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=dos

image=/boot/vmlinuz-2.4.2-0.1.49
	label=linux
	read-only
	root=/dev/hda3

other=/dev/hda1
	label=dos
--
Lamar Owen
WGCR Internet Radio
1 Peter 4:11
Comment 1 Preston Brown 2001-04-12 17:03:34 EDT
I believe this was fixed in 0408.  Adrian, can you verify?
Comment 2 Jay Turner 2001-04-13 10:01:11 EDT
This is fixed in the latest up2date-2.5.3-1 which should be going out as soon as
it makes it way through QA.

Note You need to log in before you can comment on or make changes to this bug.