Bug 3576 - solemul: how do I run solaris programs (no kernel support?)
solemul: how do I run solaris programs (no kernel support?)
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
sparc Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-18 13:38 EDT by Don Beusee
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 17:04:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Don Beusee 1999-06-18 13:38:50 EDT
I have solemu installed, which seems to be the latest iBCS
package, yet I cannot run any solaris programs.  Most of
them simply say 'killed'.  Running strace on any solaris
program shows only this:
execve("/usr/local/bin/calc", ["calc"], [/* 69 vars */]) = 0
syscall: SunOS no support
Reading /usr/doc/solemul-1.1/README indicates I should do:
insmod solaris
but where is this module?  The solemul package does not
contain any 'modules'.  The README file also says:
 (assuming you have the Solaris kernel module compiled
- see kernel documentation how to do that)
but I cannot find any such documentation.  And anyway,
shouldn't installing solemul be enough?
Comment 1 Don Beusee 1999-09-30 08:37:59 EDT
Why was this bug marked resolved, and with no comments?  I did not
receive any answer to this and I've been waiting a long time!!
Comment 2 Don Beusee 2000-03-07 05:21:59 EST
Happens with 6.1 also.  Setting version to 6.1.
Comment 3 Jeff Johnson 2000-03-07 07:05:59 EST
It's not enough to just install the solemul package, as you will also need to
add solaris libraries. The solaris module resides in
/lib/modules/*/misc/solaris.o, and appears not to be present in the 6.1
(or 6.2) kernel package.
Comment 4 Jeff Johnson 2000-03-07 07:27:59 EST
From davem@redhat.com:
   Date: Tue, 7 Mar 2000 07:15:02 -0500
   From: Jeff Johnson <jbj@redhat.com>

   I just noticed that the 6.2 kernel has not the solaris module
   needed by solemul. Oversight or non-functional?

It's not fully functional so we really don't want
to include support for it.

However we do want to keep the solemu rpm around
so that when it is functional, the distribution
level infrastructure is already there waiting for
it.

Changing component to kernel because that's where the fix will be.
Comment 5 Pete Zaitcev 2001-05-02 17:04:36 EDT
How about marking this DEFERRED?
Comment 6 Ben LaHaise 2002-06-03 17:36:21 EDT
This is unlikely to get fixed as SPARC releases are no longer being made.

Note You need to log in before you can comment on or make changes to this bug.