Bug 357951 - id3tags with trailing space are ignored
id3tags with trailing space are ignored
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-30 05:55 EDT by Herbert Gasiorowski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.10.1-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:57:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herbert Gasiorowski 2007-10-30 05:55:40 EDT
Description of problem:
mp3 songs with id3 tags (e.g.album title) which ends in a space character
are shown as "unknown" (e.g.album)

Version-Release number of selected component (if applicable):
rhythmbox-0.10.1-2.fc7

How reproducible:
allways

Steps to Reproduce:
1. Create a mp3 with an id3tag with a space at the end: e.g. album="test "
2. Rescan the folder with this song in rhythmbox
3. search for "unknown"
  
Actual results:
Song is listed as "unknown" Album

Expected results:
Actual album title should be shown

Additional info:
It does not make sence to have tags with trailing spaces but it took me quite
long to find the reason for several "unknown" albums.
It should be corrected someday ...
Comment 1 Bastien Nocera 2007-10-30 13:28:39 EDT
Came back to bite me that one. Fix of my fix is:
http://svn.gnome.org/viewvc/rhythmbox?view=revision&revision=5146

Needs fixing in F-7, F-8 and devel.
Comment 2 Bastien Nocera 2007-10-30 14:48:46 EDT
Please try the binaries that will shortly pop up at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=220791
Comment 3 Herbert Gasiorowski 2007-10-31 03:27:11 EDT
it seems to work : rhythmbox-0.10.1-5.fc7

(but only on the second try - maybe the library was not scanned before)
Comment 4 Bastien Nocera 2007-10-31 06:34:03 EDT
(In reply to comment #3)
> it seems to work : rhythmbox-0.10.1-5.fc7
> 
> (but only on the second try - maybe the library was not scanned before)

I don't understand what you mean there. Were the songs already in the database
when you tried importing them again?
Comment 5 Herbert Gasiorowski 2007-10-31 06:59:08 EDT
Yes:

What I did is (as far as I remember):
1. Create a MP3 with and ID3Tag ending on a space character
2. Try the old version (-2.fc7) to see if the album is actually "unknown"
3. Install the new version (-5.fc7)
4. Start rhytmbox again - and the album was still on "unknown"
5. Import the folder - no change!
6. Restart rhythmbox - and all was fine - album was set correctly

Probably of topic:
After this I did some changes on other ID3tags and the songs disapear from
the rhythmbox - maybe after I set the preference to
"Watch my library for new files".
After a restart of rhythmbox, all changes where correctly displayed.
Should I check this - with the old version too? - and file another bug???
Comment 6 Bastien Nocera 2007-10-31 07:14:14 EDT
(In reply to comment #5)
> Yes:
> 
> What I did is (as far as I remember):
> 1. Create a MP3 with and ID3Tag ending on a space character
> 2. Try the old version (-2.fc7) to see if the album is actually "unknown"
> 3. Install the new version (-5.fc7)
> 4. Start rhytmbox again - and the album was still on "unknown"
> 5. Import the folder - no change!

That's because the file is already in the database, and hasn't changed, so
Rhythmbox would have no reasons to rescan it (the bug is in the metadata parser).

> 6. Restart rhythmbox - and all was fine - album was set correctly

That means the patch worked correctly then. I'll add it to F-8 and devel.

> Probably of topic:
> After this I did some changes on other ID3tags and the songs disapear from
> the rhythmbox - maybe after I set the preference to
> "Watch my library for new files".
> After a restart of rhythmbox, all changes where correctly displayed.
> Should I check this - with the old version too? - and file another bug???

I don't understand what you did there. File another bug with precise instructions.
Comment 7 Fedora Update System 2007-11-09 18:53:32 EST
rhythmbox-0.10.1-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rhythmbox'
Comment 8 Fedora Update System 2007-11-26 13:57:03 EST
rhythmbox-0.10.1-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.