Bug 35822 - Dell ws220/330 and agpgart
Summary: Dell ws220/330 and agpgart
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-12 18:33 UTC by Rogelio Noriega
Modified: 2007-04-18 16:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 18:43:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "lspci; lspci -n" on Dell WS 530 (2.16 KB, text/plain)
2001-04-17 20:16 UTC, Yu-Pa Ng
no flags Details
Output of "lspci; lspci -n" on Dell WS 220 (1.45 KB, text/plain)
2001-04-17 20:17 UTC, Yu-Pa Ng
no flags Details
output of `lspci -vn` (2.62 KB, text/plain)
2001-05-02 18:10 UTC, Yu-Pa Ng
no flags Details

Description Rogelio Noriega 2001-04-12 18:33:57 UTC
When using add-on Matrox G450 graphic card on Dell WS 220 and 530, 
agpgart is not probed.  I need to force it using "modprobe agpgart 
agp_try_unsupported=1" command

Comment 1 Mike A. Harris 2001-04-13 14:40:55 UTC
We have force loaded agpgart on mga and r128 for a while now.

Comment 2 Preston Brown 2001-04-13 15:55:12 UTC
Bill, is this a agpgart driver issue with the WS220's chipset?


Comment 3 Bill Nottingham 2001-04-13 16:12:30 UTC
Probably, yes, if we need to add the 'agp_try_unsupported' parameter.

Comment 4 Matt Wilson 2001-04-17 18:51:56 UTC
as a workaround, add:

options agpgart agp_try_unsupported=1

to /etc/modules.conf


Comment 5 Matt Wilson 2001-04-17 18:54:24 UTC
please add the output of "lspci; lspci -n" to this bugreport.


Comment 6 Yu-Pa Ng 2001-04-17 20:16:59 UTC
Created attachment 15564 [details]
output of "lspci; lspci -n" on Dell WS 530

Comment 7 Yu-Pa Ng 2001-04-17 20:17:56 UTC
Created attachment 15565 [details]
Output of "lspci; lspci -n" on Dell WS 220

Comment 8 Mike A. Harris 2001-05-02 17:46:39 UTC
I need "lspci -vn" to get the subvendor id.  This G450 card is not supported
currently.  *ANY* G450 card that shows up as G400, automatically is unsupported
by XFree86, and requires at a minimum the output of "lspci -vn" to be submitted
for the card to be detected properly in some future version of XFree86.

This is a bad side effect of using subvendor id's on PCI cards..  nothing much
can be done about it until the XFree86 team is made aware of new PCI ID's.

Comment 9 Yu-Pa Ng 2001-05-02 18:10:17 UTC
Created attachment 17067 [details]
output of `lspci -vn`

Comment 10 Bill Nottingham 2001-05-02 18:29:25 UTC
This is solely a kernel agpgart issue. Dunno why it's assigned
to X.

Comment 11 Mike A. Harris 2001-05-02 18:41:10 UTC
Ok, the 0641 pci id is in kudzu already.  It must have been added after
RHL 7.1 was released...

I looked into the XFree86 code and I do not see any sane way of working around
this problem inside XFree86.  If the above workaround works, please use it for
the time being.  As far as I am concerned, this is a hardware/kernel issue, not
an XFree86 issue.


Comment 12 Mike A. Harris 2001-05-02 18:42:59 UTC
Whoops.. looks like we had a mid air collision there bill..  Reassigning to
kernel..


Note You need to log in before you can comment on or make changes to this bug.