Bug 35826 - USB file system hangs (cannot unmount) when installer shutsdown
USB file system hangs (cannot unmount) when installer shutsdown
Status: CLOSED DUPLICATE of bug 30696
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-12 15:48 EDT by John Beckmann
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-25 13:17:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Beckmann 2001-04-12 15:48:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)


USB file system /proc/bus/usb hangs when the install process trys to 
unmount the USB file system during shutdown, after completing a sucessful 
install.

Reproducible: Always
Steps to Reproduce:
1.Run install from CD, with USB Logitech Cordless Trackman mouse
2.Install runs perfectly in defaul mode. i.e. high res graphical.
3.Restart after sucessful install.
	

Actual Results:  /proc/bus/usb hangs when unmounting
Resorted to removing power from system. The system then start perfectly in 
shell mode (init 3), but hangs if if you run startx.

Expected Results:  System should just restart without hanging.

If the USB mouse is replaced with a PS/2 mouse, the system works without 
any problems. The USB mouse works with the RedHat 7.0
Comment 1 Pete Zaitcev 2001-06-25 16:25:15 EDT
This bug seems to be twofold:
1. Well known hang on umount;
2. Hang of startx, which seems to be unrelated.


*** This bug has been marked as a duplicate of 30696 ***

Note You need to log in before you can comment on or make changes to this bug.